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1 Introduction

This manual describes the installation, the configuration and the usage of the payment module
for OpenCart and DocData.

Before you can start with the installation please make sure that you hold all the necessary data.
You need:

® DocData Merchant Name

® DocData Merchant Password

® QOpenCart Payment module from sellxed.com/shop
® |ogin datatoyour server and shop

Note that you must use at least PHP version 5.6 for our plugins. PHP 8 or higher is currently not
supported.

1.1 Procedure of the installation

with this document you'll get all the information you need for the installation of the module. For
the implementation of the module you should follow the checklist strickly. Only like that you can
ensure a safe usage in accordance to all security regulations.
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1. Configuration of the DocData Settings

2. Configuration of the main module

3. Configuration of all the accepted Payment method with the authorization methods
included

4. Process a test order

5. Activation of yourDocData account

Installation Service

Our payment plugins should have per default the correct settings for most of our
customers' preferences. That means once you have entered the required credentials in
the plugin configuration to connect your account to your website, the plugin should be
fully operational. Should you be willing to receive detailed information on a setting you
do not know, you may contact our support team who will be able to assist you further.

Our support team is at your disposal during regular business hours at: http://www.
sellxed.com/support. Furthermore, you have the option of ordering our installation
service. We will make sure the plugin is installed correctly in your shop: http://www.
sellxed.com/shop/de/integration-und-installation.htmi

.htaccess Directory Protection

In order to test the module, any kind of directory protection or IP blocking on your server
must be deactivated. This is crucial as otherwise the payment feedback of DocData might
not get through to the shop.

1.2 System Requirements

In general, the plugin has the same system requirements as OpenCart. Below you can find the
most important requirements of the plugin:

® PHP Version: 5.4.x or higher

® OpenSSL: Current version with support for TLS 1.2 or higher.

* fsockopen: The PHP function fsockopen must be enabled. The plugin must be able to
connect to external systems over the Internet.

® PHP Functions: All common PHP functions must be enabled.

In case you are using OpenCart version 3.0.3.5 or 3.0.3.6, you must patch your store to fix the twig
extension error in order for modified templates to be loaded. The following extension can be
used to resolve the issue: https://www.opencart.com/index.php?route=marketplace/extension

/info&extension id=40469.
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2 Configuration DocData - Backend

You'll find an overview about transactions and settings in the backend from DocData:

® Testenvironment:https://test.docdat apaynents. com ps/comtripl edeal.
paynment servi ce. backof fice. Login

® Live environment: htt ps: //backoffi ce. docdat apaynments. coni ps/ com
tripl edeal . paynment servi ce. backoffice.lLogin

2.1 Configuration of the main module

Fill the merchant name and merchant password in the main configuration of the module You can
there additionally choose a default. The default CSS matches the deposited standard CSS
configuration in DocData. You can overwrite these setiings in theconfiguration of the payment
method.

Choose if you want to process the payments in live or test mode.
2.2 Configuration of the payment methods
You can undertake various adjustments for each payment method.

Please keep in mind that in case you want to use the Payment Method Bank Transfer or Open
Invoice (Klarna and AfterPay) you need to activate the feature extendedStatusRequests at
DocData.

2.21 CSSID

Define for each payment method your CSS ID, which you have already set in the backend of
DocData. You can define the CSS profile under Settings > Edit Look and Feel
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| To create a new css, click here! | New css

1 % Select ces

M resets the avtomatic margin and padding of the browser */f
{ |body, html |
margirn:0;
padding:d;
i
*irealid {
box-shadow: none;
[ |
| |= {

!
M sets the standard font *f

af

outline:none;

colon#83A000;
cursor:pointer;

}
body {

color#333;
[ font:12px/18px arial, helvetica, sans-serif;
| background:url(“img/bg_repeater_header.png”) top center repeat-x;

i
| mainLayout{
background:url“ima/alcbe.png”) right bottom no-repeat;
¥
| | headerTitle]
font-weight:beld,

paymentChoiceMenuRow{ i

Figure 2.1: Create CSS profiles under settings > Edit Look and Feel.

2.2.2 Payment Profile

Wwith the payment profile you can select a payment method for the payment page. To do so you
need to create a profile for each payment method in the backend of DocData.

Under Edit > Payment method and names you can create profiles and assign to every profile a
payment method. Fill in the name of the profile into the configuration of the payment method.
This results in the pre selected display of this payment method.
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Assign payment methods to a profile

Select profile: | AMEX + |Add & delete profiles

Available payment methods

AFTERPAY _OPEN INVOICE Selected
BANK_TRANSFER AMEX

EBANKING Add >

ELV

IDEAL

MAESTRO

MASTERCARD

MISTERCASH

PAYPAL EXPRESS CHECKOUT
SEPA DIRECT DEBIT

<« Remove

VISA
First
Up
Diovern
Last
Store changes

Figure 2.1: Creation of payment profiles to select the payment method under Edit > Payment
method and names.

You'll find more information to the configuration of the payment methods and the significance of
the particular settingshere.

2.3 Activation of the Cron Jobs

Since the DocData doesn't send notification answers it can happen that the customer closes the
window before finishing the transaction. In this case we recommend to install Cron Jobs in your
shop. Further information you'll find in the chapterCron Job

2.4 Testing and Activation of the Module

After the activation and configuration of the payment methods, test your module with the test
datayou find in the manual. If the tests were successful, switch to Live in your main module.
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3 Module Installation and Update in the
OpencCart Shop

3.1 Installation

At this time you should already be in possession of the module. Should this not be the case, you
can download the necessary files in your customer account in the sellxed shop (Menu "My
Downloads Downloads"). In order to install the module in your shop, please carry out the
following steps:

1. Download the plugin. The download can be found in your sellxed.com account under "My
Downloads".

2. Unzip the archive you have just downloaded.

3. Inthe unzipped folder navigate to the folder "files"

4. For some shops there are different versions of the plugin provided. If this is the case open
the folder which corresponds to your shop version.

5. Usingyour preferred FTP client upload entire content of this folder into the root directory
of your shop. For some shops there is a specific folder containing the plugins. If that is the
case upload the plugin into this folder. Make sure that the folders aren't replaced but
merely merged.

6. If you haven't yet done so, log back into your shop.

3.2 Updates and Upgrades

You have direct and unlimited access to updates and upgrades during the duration of your
support contract. In order to receive constant information about available updates we ask you to
subscribe to our RSS feed that we publish for your module.

More information regarding the subscription of this RSS feed can be found under: http://www.
sellxed.com/en/updates_upgrades.

We only recommend an update if something doesn't work in your shop, if you want to use new
feature or if there is a necessary security update.

3.2.1 Update Checklist

We ask you to strictly comply with the checklist below when doing an update:
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1. Always do a backup for your database and your files in your shop

2. Use always a test system to test the update process.

3. Wait until all the files are copied to the shop, clear the cache if there is one in your shop
and then visit the configuration page of the main module so that the update process will
be initialized.

Do not do updates directly in the live environment

Please test the update procedure first in your test shop. Our support team is able and
willing to help you if you experience problems with the update process. However, if you
decide to perform the update directly in your live shop there is the possibility of a
downtime of the shop of more than two days depending on the availability of our support
if you do not want to book our complementary support.

Depending on the version it could be that the database has to be migrated. We recommend you
therefore, to perform the updates in times when the shop is not visited too frequently by your
customers.

3.2.2 Update Instructions

Please always read the update instruction. Those instructions can be found in the changelog. If
there are no special remarks, you can proceed by just overwriting the files in your system.
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4 Module Configuration in the OpencCart Shop

The configuration consists of two steps. The first step is the configuration of the main module
with all the basic settings (cf. Configuration of the Main Module). During the second step you can
then carry out individual configurations for each payment method . This allows for full flexibility
and perfect adaptation to your processes.

Create backups!

Please create a backup of the main directory of your shop. In case of problems you will
then always be able to return your shop to its original state.

We furthermore recommend testing the integration on a test system. Complications may
arise with third party modules installed by you. In case of questions, our support is gladly
at your disposal.
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5 OpencCart 3.0 Installation - Additions

In order to guarantee smooth operations and the usage of all features please make sure that you
follow the instructions below.

5.1 Configuration of the Main Module

You will find the settings for the main module under "Extension > Modules > DocData Base
Module" . Install the module by clicking Install.

By clicking Edit you can configure the main module. Enter all data in the corresponding fields.
Each option is, furthermore, explained in short info texts in the shop.

5.2 Configuration of the Payment Module

After having successfully configured the main module, you can find the settings for the individual
payment methods in your shop under Extensions > Payments . Each payment method is listed
individually. Install the payment methods you wish to offer to your customers. You can carry out
individual settings for each payment method and thereby optimally adapt the payment methods
to your existing processes. The most central options are described in more detail further below.

By clicking on Install the payment method is activated in your shop. Click Edit in order to modify
the configuration of the payment method.

5.3 Direct Capturing of Transactions

The option "Capture" allows you to specify if you wish to debit payments directly or if you first
wish to authorise them and then debit the payment at a later point.

Depending on your acquiring contract, a reservation is only guaranteed for a specific period of
time. Should you fail to debit the payment within that period, the authorisation may therefore no
longer be guaranteed. Further information on this process can be found below.

Different settings between DocData and the module

It may be that settings saved in the payment modules overwrite settings saved in
DocData.

5.4 Uncertain Status

You can specifically label orders for which the money is not guaranteed to be received. This
allows you to manually control the order before shipment.
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5.4.1 Setting the order state

For each payment method you may select in which state the order should be set to depending on
the booking state. This is the initial state of the order.

5.5 Optional: Validation

Note: It can be that this option is not visible in your module. In this case just ignore this section.

with the option 'validation' you can define the moment when the payment method should be
made visible to the customer during the checkout process. This setting is relevant for modules
where the usage depends on the customer's compliance with specific preconditions. For
example, if a solvency check has to be carried out or if the payment method is only available in
certain countries. In order for the credit check or address validation to also work with European
characters, the charset of the "Blowfish mode" must be set to "UTF-8" for certain PSP settings.

You have the choice between these options:

e Validation before the selection of the payment method: A validation verification is carried
out before the customer selects the payment method. If the customer does not fulfill the
requirements, the payment method is not displayed

¢ Validation after selection of the payment method: The verification of the compliance
occurs after the selection of the payment method and before the confirmation of the order

¢ During the authorisation: The validation verification is carried out by DocData during the
authorisation process. The payment method is displayed in any case
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6 Settings / Configuration of Payment Methods
6.1 General Information About the Payment Methods

The plugin contains the most common payment methods. In case a desired payment method is
not included per default, please contact us directly.

In order to be able to use a payment method, it must be activated in your account with DocData
as well as in your shop. Information about the configuration of the payment methods can be
found further above.

Below you can find important information for specific payment methods that deviate from the
standard process.

6.2 Information on Payment Status

For each payment method you can define an initial payment status (status for authorized
payments etc.). You hereby define the payment status for each state depending on the
processing type of the order (captured, authorized, etc.). It's the initial status which the order
assumes. Depending on the mutation carried out by you, the status can change.

Important info regarding Order Status

Never set the status to Pending DocData or any similar pending status which is
implemented by the module.

6.2.1 Order status "pending" / imminent payment (or similar)

Orders with the status 'pending DocData' are pending orders. Orders are set to that status if a
customer is redirected in order to pay but hasn't returned successfully or the feedback hasn't
reached your shop yet (Customer closed window on the payment page and didn't complete
payment). Depending on the payment method these orders will automatically be transformed
into cancelled orders and the inventory will be cleared (so long as the Cronjob is activated). How
long this takes depends on the characteristics of the payment method and cannot be configured.

If you have a lot of pending orders it usually means that the notifications from your webserver to
DocData are being blocked. In this case check the settings of your firewall and ask the Hoster to
activate the IPs and User Agents of DocData.

6.2.2 Order status "cancelled"

Orders with the status "cancelled" have either been set to that status automatically due to a
timeout, as described above, or have been cancelled directly by the customer.
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7 The Module in Action

Below you will find an overview of the most important features in the daily usage of the DocData
module.

7.1 Useful Transaction Information on the Order

You can find an overview of the transaction information in within the order detail view. Among
others, this information allows for the definite attribution of the orders to their corresponding
transaction, seen in the backend of DocData.

[E] orders

Order Detalls Grder D 2

nvoice No [ Generate ]

Payment Details

Shipping Detalls Store Name Your Store

: D: X £ .
Products Store Url. hitp:lidemo.sellxed.com

Customer. Sascha krisi

History

Customer Group: Default

E-Mail: info@customweb.ch

Telephone 33123456798

Total: 78.90€

Order Status: Pending

IP Address: 1608515547

User Agent Mozilla/5.0 (X11; Linux xi B6_64) AppleWebKit’537 36 (KHTML, like Gecko) Ubuntu Chromium/30.0.1589.114 Chrome/30.0.1599.114 Safari/537 36
Accept Language: de,en-US;g=0.8.en,q=0.6

Date Added. 13/11/2013

Date Modified: 13M11/2013

Figure 7.1: Transaction Information in OpenCart.

7.2 Using Invoice Details of a Processor

In the following context you can view or embed the "payment details" of for example an "Open
Invoice" transaction:

7.2.1 OpenCart Order Confirmation (E-Mail)

The "payment information” will be visible in the default "order confirmation e-mail" of OpencCart.

7.2.2 OpenCart Invoice (PDF)

This feature is not available by default in OpenCart that s why it can not be supported by the
payment gateway module.
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7.2.3 OpenCart-Backend (Transaction details)

You can view the payment and transaction details in OpenCart under Sales > DocData
Transactions. If you can not find this menu point you have to clear the OpenCart modifications
under Extensions > Modifications >.

Authorization Type
Order Status
Recurring

Created At

Updated At

Alias Active
Authorisation Amount
Currency

Payment Method
Payment ID

Test Transaction
Transaction authorised
Transaction uncertain

Transaction paid

PaymentPage New Authorization
authorized

No

2017-03-06 15:22:26
2017-03-06 15:22:45
Yes

20.3

EUR

Open Invoice
3571832

Yes

Yes

No

Yes

Transaction History

Date

2017-03-06 15:22:45

Action Message

authorization The amount of 20.30 is authorized.

Payment Information e

HTML

TEXT

Bank: Customweb Test Bank

Account Holder: Customweb GmbH
IBAN: DE2501200000TESTO00000000003
BIC: TESTBIC0003

Reference Number: BP3571832/2749

Bank: Customweb Test Bank

Account Holder: Customweb GmbH
IBAN: DE2501200@0@TESTO0R000000003
BIC: TESTBIC@8@3

Reference Number: BP3571832/2749

Figure 7.1: Transaction details within OpencCart.

7.2.4 OpenCart Success-Page

Due to technical limitations, it is currently not possible to display the "payment information"”

here.

7.3 Capturing / Cancelling of Orders
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7.3.1 Capturing Orders

In order to capture orders, open the transaction manager under Sales > DocData Transactions.
Here you will find an overview of all transactions. Search for the order in the field with the order
numbers. By clicking "view" you will open the transaction of the order.

7.3.1.1 Capturing Complete Orders or Partial Capturing

By clicking the button "Capture Transaction" a new window opens up. You can now capture every
item individually in case you do not wish to send all items at once. The amount of possible partial
captures depends on your contract. Please contact DocData directly in order to clarify questions.

Capturing of Orders in the backend of DocData

The transaction management between your shop and DocData is not synchronised. If you
capture payments with DocData, the status in the shop will not be updated and a second
capturing in the shop is not possible.

In case you do not wish to capture all items of an order, you can close the transaction by clicking
the box.
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With the following form you can perform a partial capture.

Name SKU Type Tax Rate
iPhone product 11 product 0%
Flat Shipping Rate shipping shipping 0%

Figure 7.1: Capturing of Orders

Partial Capturing

Quantity Total Amount (excl. Tax) Total Amount (incl. Tax)
1 | 74.24 | 74.24
1 | 3.68 | 3.68

Total Capture Amount: 77.91 EUR

Close transaction for further captures

Capture

Please find out if the capturing of partial amounts is supported by your DocData contract.
If this is not the case, it might happen that the transaction is closed for further

transactions after a partial capture.

7.3.2 Cancel Orders

By clicking "Cancel Transaction", the transaction is cancelled and the reserved amount on your

customer's card is released automatically.

Capture Transaction

Figure 7.1: Capture or Cancel in OpenCart.

7.4 Refunding Orders

Refund Transaction

In order to refund orders, open the transaction information (cf. above).

You can refund individual items or any amount of your choice by modifying the total amount or

the item quantity.
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PARTIAL REFUND

With the following form you can perform a partial refund.

MName SKU Type Tax Rate Quantity Total Amount (exel. Tax) Total Amount (incl. Tax)

iPhone product11  product 0% | 1 | 74.24 [ 7424

Flat Shipping Rate shipping shipping 0% I 1 I 3.68 I 368
Total Refund Amount: 7791 EUR

Close transaction for further refunds

Figure 7.1: Refunds in OpenCart for DocData.

Maximal Refund

With our module it is not possible to refund more than 100% of the originally authorised
amount.

Executing a refund will not change the status of the order.

7.5 Setup a CronJob to Activate the Timed Operations

To activate the timed operations of the plugin (e.g. update service, deleting pending orders, etc.)
make sure that you set up the OpenCart Cron engine. Especially the update function allows you to
automatically retrive additional information or changes of your order directly via the APl of
DocData. Please note it could be that in order to use the update feature it may be necessary that
DocData activates additional options in your account.

In order to use the timed operations, please schedule a cron job in your server to the following
controller:

https://www.your-shop.com/index.php?route=docdatacw/cron/cron

Here we suggest you use a Cron Engine like for example EasyCron. That way you can This allows
you to open the file (URL) with an external service.

20/ 27


https://www.easycron.com?ref=39190

8 Testing
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Before switching from test to live mode it is important that you test the module extensively.

Testing

Do not forget to switch the operating mode from test to live after having successfully

tested the module.

8.1 Test Data

In the following section you can find the test data for the various payment methods:

Credit / Debit Card
VISA

Card number
Expiry Date

Name

CID

3D-Secure

Mastercard
Card number
Expiry Date
Name

CID
3D-Secure

American Express
Card number
Expiry Date
Name

CID

Maestro
Card number
Expiry Date
Name

CID
3D-Secure

Bancontact Mister Cash

Card number
Expiry Date
Name

CID

MasterCard

41111111 11111111
03/2027

Hans Muster

333

ECI=5

5100 0000 0000 0008
03/2027

Hans Muster

333

EClI=2

341111111111 111
03/2027

Hans Muster

2234

6703 0500 0340 17105
09/2022

Hans Muster

333

ECI=2

6703 0500 0340 53002
09/2022

Hans Muster

333

VISA

Mastercard

American Express

Maestro

Bancontact Mister Cash

21/27



Mastercard
Card number
Expiry Date
Name

CID
3D-Secure

Maestro
Maestro
Card number
Expiry Date
Name

CID
3D-Secure

Visa

VISA

Card number
Expiry Date
Name

CID
3D-Secure

American Express
American Express

Card number
Expiry Date
Name

CID

Bancontact

Bancontact Mister Cash

Card number
Expiry Date
Name

CID

5100 0000 0000 0008
03/2027

Hans Muster

333

EClI=2

6703 0500 0340 17105
09/2022

Hans Muster

333

EClI=2

41111111 11111111
03/2027

Hans Muster

333

ECI=5

34111111 1111111
03/2027

Hans Muster

2234

6703 0500 0340 53002
09/2022

Hans Muster

333

sellxed

Mastercard

Maestro

VISA

American Express

Bancontact Mister Cash
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9 Errors and their Solutions

You can find detailed information under http://www.sellxed.com/en/fag. Should you not be able
to solve your problem with the provided information, please contact us directly under:
http://www.sellxed.com/en/support

9.1 The Referrer URL appears in my Analytics Tool

when a customer and the notification are redirected via Header Redirection, the DocData
Referrer URL might appear in your Analytics Tool thus hiding the original traffic source. However,
most Analytic Tools are able to minimize this problem.

In case you are using Google Analytics as reporting tool, this step by step guide may help you to
exclude the URLs: under bullet point 4.
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10 Compatibility with Third-Party Plugins

The plugins listed below are compatible with our payment modules and allow you to handle
certain tasks in an easier way.

10.1 Birthday and gender in OpencCart

For certain payment service providers it is necessary to check the birthday and the gender of a
customer. OpenCart does not check this by default.

How to enable gender and birthday checks in your shops checkout

1. Add two new custom fields to your checkout via your shops backend under
"Customers > Custom Fields"

2. Modify the order context getters to return the value of your custom checkout field
from the order / session (or wherever the previous step saves the data).

Order Context Getters

® AbstractOrderContext
* getBillingDateOfBirth()
* getBillingGender()

These functions can be found in  "system/library/cw/DocData
/AbstractOrderContext.php".
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11 Error Logging

The module will log different unexpected errors or information depending on the configured
level. If there is any issue with the module, this l0og can help identify the cause.

11.1 Log Levels

You can configure the log level in the DocData settings.

® Error: Logs unexpected errors only. (Default)
* [nfo: Logs extended information.
® Debug: Logs information helpful for debugging.

11.2 Log Location

The log file is stored in the default log folder of OpenCart. The path is configured in the config.php
of your shop system. (Default Path: {shopRootDirectory}/system/logs or {shopRootDirectory}
/system/storage/l0gs)
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12 Advanced Information

This section of the manual is for advanced usage of the module. The content is for advanced
users with special requirements. Everything in this section is optional and not required for the
daily usage of the module.

12.1 Transaction Object

This section describes how to extract information from a transaction, if you need it for further
processing. E.g. you require more information of the transaction for further processing an order
inyour ERP system.

The code snippets in this section assume your script resides in the root folder of the shop with
the default shop folder structure.

In your script initialize the base of OpencCart.
Opencart 3.x

requi re_once(' config. php');
require_once(DI R_SYSTEM . 'startup.php');
/'l Registry

$registry = new Registry();

/1 Config

$config = new Config();

$config->l oad(' default');

$confi g->l oad(' catal og');

$registry->set('config', $config);

$l oader = new Loader ($registry);

$registry->set('load' , $loader);

$registry->set('db', new DB($config->get('db _type'), $config->get

(' db_hostnane'), $config->get (' db_usernane'), $config->get

(' db_password'), $config->get('db_database'), $config->get('db_port')));

Include the module specific files and set registry.

require_once DIR SYSTEM ' |ibrary/cw init.php';

requi re_once DIR_SYSTEM ' library/cw DocDataCw Util . php'

require_once DIR SYSTEM ' | i brary/cw DocDat aCw Entity/ Transacti on. php';
DocDat aCw _Uti|::setRegistry($registry);

Now you can load the transaction and then extract the transactionObject.
Load the transaction by Id:

$transactionByld = DocDataCw Entity Transaction::|oadByl d($transactionld);
$transacti onChj ect = $transacti onByl d->get Transacti onCbj ect () ;

Load transactions by Order ID:
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$transacti onsByOrderld = DocDataCw Entity_Transaction::

get Transacti onsByOrder | d( $orderld);

foreach($transacti onsByOrderld as $transaction){
$transacti onObj ect = $transacti on->get Transacti onObj ect ();
/1 Do sonething with each object
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