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1 Introduction
This manual explains the installation, configuration and usage of the payment module for
OpenCart and Viveum. It is important that you strictly follow the described steps. Only by doing
so, a secure usage in compliance with all security regulations can be guaranteed.
Before beginning with the installation, please make sure that you are in possession of all
necessary data:
PSPID & Password. You receive these credentials from Viveum after conclusion of contract.
Our support staff is happy to help you acquiring a Viveum contract if you do not yet have
one.
OpenCart payment module from sellxed.com/shop
FTP access to your server
Login credentials for your shop
Note that you must use at least PHP version 5.6 for our plugins. PHP 8 or higher is currently not
supported.

1.1 Procedure of the Installation
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1.
2.
3.
4.
5.

Configuration of the administration interface of Viveum.
Upload of the module
Configuration of the basic settings of the payment module
Configuration of the payment methods
Carrying out a test purchase by means of the attached test data at the end of this
document
6. If the test was successful, copy all data from your test account into the Viveum live
account.

Installation Service
Our payment plugins should have per default the correct settings for most of our
customers' preferences. That means once you have entered the required credentials in
the plugin configuration to connect your account to your website, the plugin should be
fully operational. Should you be willing to receive detailed information on a setting you
do not know, you may contact our support team who will be able to assist you further.
Our support team is at your disposal during regular business hours at: http://www.
sellxed.com/support. Furthermore, you have the option of ordering our installation
service. We will make sure the plugin is installed correctly in your shop: http://www.
sellxed.com/shop/de/integration-und-installation.html

.htaccess Directory Protection
In order to test the module, any kind of directory protection or IP blocking on your server
must be deactivated. This is crucial as otherwise the payment feedback of Viveum might
not get through to the shop.

1.2 System Requirements
In general, the plugin has the same system requirements as OpenCart. Below you can find the
most important requirements of the plugin:
PHP Version: 5.4.x or higher
OpenSSL: Current version with support for TLS 1.2 or higher.
fsockopen: The PHP function fsockopen must be enabled. The plugin must be able to
connect to external systems over the Internet.
PHP Functions: All common PHP functions must be enabled.
In case you are using OpenCart version 3.0.3.5 or 3.0.3.6, you must patch your store to fix the twig
extension error in order for modified templates to be loaded. The following extension can be
used to resolve the issue: https://www.opencart.com/index.php?route=marketplace/extension
/info&extension_id=40469.
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2 Configuration Viveum - Backend
For the configuration, log into the Viveum backend:
Test Environment: https://viveum.v-psp.com/ncol/test/backoffice
Live Environment: https://viveum.v-psp.com/ncol/prod/backoffice
The settings carried out on the following pages are a precondition for the configuration of the
main module.
The configuration of the settings is done under Configuration > Technical Information. In the
following chapter the chapter titles correspond to the tabs in the back office of Viveum. For some
parts screenshots will be added for a more precise illustration. Should a specific setting not be
mentioned then it has no importance for the configuration of the payment module and can be
ignored by you as such.

2.1 Tab: Global Transaction Parameters
Under the tab Global Transaction Parameters you define the basic settings for the processing of
transactions.

2.1.1 Default operation code and default data capture procedure
We recommend choosing Sale and "Automatic data capture by our system at the end of the day".
All incoming payments will be directly processed and debited. If you are using transaction
management and deferred capturing we strongly advise to use these settings. In case you have
saved different settings in the module, then the module's settings will overwrite those of the
Viveum.

2.1.2 Payment Retry
We recommend entering 10.

2.1.3 Processing for Individual Transactions
We recommend the option "Online but switch to offline when the online acquiring system is
unavailable"".

2.2 Tab: Global Security Parameters
Here you define the security parameters for the interaction between your shop and the gateway
of Viveum.
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2.2.1 Hashing Method
The sellxed payment modules support all hashing methods. In order for the module to function, it
is crucial that the settings saved with Viveum correspond to those made in the backend of your
shop.
In order to guarantee a smooth processing of payments, we recommend the following hashing
methods:
Each parameter, followed by the pass phrase. It may be that this parameter is not visible in
your shop. In this case it is transmitted automatically.
Hash Algorithm = SHA 512
Character Encoding = UTF-8

Figure 2.1: Configuration of the SHA-Hash.
These settings must be identical to the settings in the main module (cf. Configuration of the
main module). Please note that the character encoding in our modules is set to UTF-8 per default
and cannot be changed.

2.3 Tab: Payment Page
The checkbox under Cancel Button should be ticked. The field under Back Button Redirection can
be left empty.

2.4 Tab: Data and Origin Verification
The tab Data and Origin Verification defines security elements concerning the transmission of
data and the loading of the payment page.
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2.4.1 Checks for e-commerce & Alias Gateway
The first box under "URL of the merchant page" can remain empty.
The box "SHA-IN pass phrase" is a security element of the payment verifying its authenticity.
Therefore it is important that you use the same pass phrase in the back end and in the shop.

Customweb SHA-String Generator
Please note that only ASCII characters may be used for SHA pass phrases. Please use our
SHA pass phrase generator so that you do not enter invalid characters.

2.4.2 Checks for Viveum DirectLink and Viveum Batch (Automatic)
DirectLink allows you to use the Hidden Authorisation (Alias Gateway) as well as the direct
debiting of transactions within your shop. If you have activated DirectLInk in your account and
wish to use this feature, enter the same SHA-IN pass phrase in the box "SHA-IN pass phrase" as
above.
Further information on the configuration of DirectLink can be found under Configuration Hidden
Authorisation.

2.5 Tab: Transaction Feedback
In the tab Transaction Feedback the response of Viveum to the shop is controlled.

2.5.1 HTTP Redirection in the Browser
The parameters in the transaction feedback determine the processing in the shop after payment
has been completed. However, the four fields for "HTTP Redirection in the Browser" can remain
empty because they will be configured through the settings of our module.
Un-tick the option "I would like Viveum to display a short text to the customer on the secure
payment page if a redirection to my website is detected immediately after the payment
process."

2.5.2 Direct HTTP-Server-to-Server-Request
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The "Timing of the Request" must be set to Online but switch to a deferred request when
the online requests fail. As "Request Method" you must select "POST".
In the section General make sure that the Option: "I would like Viveum to display a
"processing" message to the customer during payment processing." is un-ticked too.
Copy here the URL that is listed in the module backend under: Extensions > Modifications
> Modules > Viveum Base Module > Edit > More > Setup.
URL on which the merchant wishes to receive a deferred HTTP request, should the status of a
transaction change offline.
For the Transaction Feedback please enter the URL that is generated in the main module. More
information can be found under the section Transaction Feedback

All orders have the status 'Pending'
Should you notice during the tests that orders are not registered in the shop and that no
confirmation email is sent, this might be due to a failure of the transaction feedback.
Make sure that your firewall is not blocking any request coming from Viveum.

Figure 2.1: Configuration of the feedback URL for the HTTP-Feedback.

Deferred Requests und Time Out
Viveum sends the notification requests with a time out of 20 sec. Should your shop not
respond to the HTTP Request within this time, a time out error will be sent. If you set the
option to Online but switch to a deferred request when the online requests fail the
request will be retrieved four times in ten minute intervals.
Please note that, depending on your Viveum subscription, it is possible that the only
option available is Always online (immediately after the payment to allow customization
of the response seen by the customer). In this case, always select this option.
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2.5.3 Dynamic e-Commerce Parameters
With this option you control which parameters are sent in the response from Viveum. In order for
payments to effectively be evaluated in your shop, all necessary parameters must be sent. It is
possible that you have other options available to select. Just make sure that you move every
parameter from available to selected except for the following:
PM
CN
SUBBRAND
AAVADDRESS
AAVCHECK
AAVMAIL
AAVNAME
AAVPHONE
AAVZIP

Figure 2.1: Configuration of the Dynamic E-Commerce Parameters. Your selection may look
differently depending on your subscription with Viveum.

2.5.4 Dynamic Parameters
With this option you control which parameters are sent in the response from Viveum. In order for
payments to effectively be evaluated in your shop, all parameters must be sent. It is possible
that you have other options available to select. Just make sure that you move every parameters
from available to selected.

Figure 2.1: Configuration of the Dynamic Parameters. Your selection may look differently
depending on your subscription with Viveum.
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2.5.5 Security for Request Parameters
The box "SHA-OUT pass phrase" is an additional safety mechanism for payments. Here too must
the entered pass phrase be identical to the one in your shop. However, please make sure that
your SHA-OUT pass phrase differs from the SHA-IN pass phrase. .

Customweb SHA-String Generator
Please note that only ASCII characters may be used for SHA pass phrases. Please use our
SHA pass phrase generator so that you do not enter invalid characters.

2.5.6 HTTP Request for Status Changes
You have the option to be informed about status changes by Viveum directly. This feature is
especially useful when a payment has an uncertain status because the acquirer system could
not be reached. The payment status will be updated automatically. Furthermore this feature
allows you to capture payments inside Viveum and have synchronize them with your shop
In order to use this feature you will have to select the option For each offline status change
(payment, cancellation, etc.).. Afterwards just copy the URL into the field that is displayed in the
Setup of your Main configuration: Extensions > Modifications > Modules > Viveum Base Module >
Edit > More > Setup.
Enter the URL shown there into the field 'URL on which the merchant wishes to receive a deferred
HTTP request, should the status of a transaction change offline.'

Figure 2.1: Enter the URL from the Setup of the Main Configuration.

2.5.7 Dynamic Parameters
Move all parameters from available to selected.

13 / 38

2.6 (Dynamic-)Template
You can now find the option template via Configuration > Template. The Dynamic Template
enables you to design the payment mask for the credit card data so it matches your web shop.
Should the field for the dynamic template not be visible, please contact Viveum. It may be that
you have to activate additional options in your account.
For the usage of the dynamic template, please save the following settings:
Enable JavaScript on template: 'No'
Our modules do not allow "usage of static template". So click 'No'
Allow usage of dynamic template: 'Yes'
In case you are using the dynamic template, enter the host name, i.e. https://Your-Shop.
com in the lower box. The upper one must remain empty.

Figure 2.1: Configuration of the Dynamic Template.

Dynamic Template
Please note that you require an SSL certificate for the usage of the dynamic template.
Otherwise the CSS-Resources will not be reloaded in certain browsers which might lead
to layout issues.

The activation of the dynamic template in the shop is explained here.

2.7 Hidden Authorisation, Ajax Authorization (FlexCheckout Hosted Tokenization Page), External Checkout & Alias Manager
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2.7.1 Preconditions
For the usage of the Hidden Authorization, Ajax Authorization (FlexCheckout), Alias Manager or
External Checkout during the payment processing, certain adjustments are necessary in the
backend of Viveum. Please check first if the options are activated in your account under Account
> Your Options.

Figure 2.1: Make sure to activate the OPC and DPR options.
If an option is not available please contact Viveum.
Options and their Meanings:
For the usage of the Hidden Authorization you require the option OnePageCheckout (OPC).
For the usage of the Ajax Authorization (FlexCheckout) you require the option
OnePageCheckout (OPC) and DirectLink (DPR).
If you additionally want to use the Alias Manager, you also need the option Alias Manager
(RECX).
In case these options are not be available, please contact Viveum directly.
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2.7.2 Setting Up an API-User
If you want to use the features of the transaction management or the hidden authorization (Alias
Gateway) you will need to set up an API user as described herafter:
Go to Configuration > User Administration and click on 'New User'. Choose a User ID and insert a
user name of your choice and your e-mail address. Select Administrator without user manager as
a profile. It is furthermore important that you select the option Special user for API (no access to
the administration). If you do not see this option, you will need to let Viveum activate the option
DirectLink for your account.

Password of the API-User
The User ID and the API-user password may only contain letters and numbers as wel as
special characters. The following special characters are not allowed: & (Ampersand), "
(double quotes), ' (single quotes)

Note down the access data. They will have to be inserted in the respective place in the
configuration of the main module.

2.7.3 Usage of External Checkouts
For the usage of external checkouts there are additional options required. External checkouts,
such as MasterPass are payment methods, which offer the possibility to transfer addresses
automatically.
The usage of the external checkouts asks for the option Direct Link and for the activation of
payment method in your account.
For the performance of the payment method, you have to make sure that under Technical
Information > Transactionfeedback in the section Direct Link all parameters selected are shifted
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Figure 2.1: Response Parameter for Direct Link.
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3 Module Installation and Update in the
OpenCart Shop
3.1 Installation
At this time you should already be in possession of the module. Should this not be the case, you
can download the necessary files in your customer account in the sellxed shop (Menu "My
Downloads Downloads"). In order to install the module in your shop, please carry out the
following steps:
1. Download the plugin. The download can be found in your sellxed.com account under "My
Downloads".
2. Unzip the archive you have just downloaded.
3. In the unzipped folder navigate to the folder "files"
4. For some shops there are different versions of the plugin provided. If this is the case open
the folder which corresponds to your shop version.
5. Using your preferred FTP client upload entire content of this folder into the root directory
of your shop. For some shops there is a specific folder containing the plugins. If that is the
case upload the plugin into this folder. Make sure that the folders aren't replaced but
merely merged.
6. If you haven't yet done so, log back into your shop.

3.2 Updates and Upgrades
You have direct and unlimited access to updates and upgrades during the duration of your
support contract. In order to receive constant information about available updates we ask you to
subscribe to our RSS feed that we publish for your module.
More information regarding the subscription of this RSS feed can be found under: http://www.
sellxed.com/en/updates_upgrades.
We only recommend an update if something doesn't work in your shop, if you want to use new
feature or if there is a necessary security update.

3.2.1 Update Checklist
We ask you to strictly comply with the checklist below when doing an update:
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1. Always do a backup for your database and your files in your shop
2. Use always a test system to test the update process.
3. Wait until all the files are copied to the shop, clear the cache if there is one in your shop
and then visit the configuration page of the main module so that the update process will
be initialized.

Do not do updates directly in the live environment
Please test the update procedure first in your test shop. Our support team is able and
willing to help you if you experience problems with the update process. However, if you
decide to perform the update directly in your live shop there is the possibility of a
downtime of the shop of more than two days depending on the availability of our support
if you do not want to book our complementary support.

Depending on the version it could be that the database has to be migrated. We recommend you
therefore, to perform the updates in times when the shop is not visited too frequently by your
customers.

3.2.2 Update Instructions
Please always read the update instruction. Those instructions can be found in the changelog. If
there are no special remarks, you can proceed by just overwriting the files in your system.
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4 Module Configuration in the OpenCart Shop
The configuration consists of two steps. The first step is the configuration of the main module
with all the basic settings (cf. Configuration of the Main Module). During the second step you can
then carry out individual configurations for each payment method . This allows for full flexibility
and perfect adaptation to your processes.

Create backups!
Please create a backup of the main directory of your shop. In case of problems you will
then always be able to return your shop to its original state.
We furthermore recommend testing the integration on a test system. Complications may
arise with third party modules installed by you. In case of questions, our support is gladly
at your disposal.
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5 OpenCart 3.0 Installation - Additions
In order to guarantee smooth operations and the usage of all features please make sure that you
follow the instructions below.

5.1 Configuration of the Main Module
You will find the settings for the main module under "Extension > Modules > Viveum Base
Module" . Install the module by clicking Install.
By clicking Edit you can configure the main module. Enter all data in the corresponding fields.
Each option is, furthermore, explained in short info texts in the shop.

5.2 Defining the URL for the Transaction Feedback
To ensure correct payment processing in your shop, at least one Feedback URL has to be
provided in the Viveum configuration. The URL to be entered can be found in your OpenCart Shop
under: ___setupForm____ > Setup

5.3 Configuration of the Payment Module
After having successfully configured the main module, you can find the settings for the individual
payment methods in your shop under Extensions > Payments . Each payment method is listed
individually. Install the payment methods you wish to offer to your customers. You can carry out
individual settings for each payment method and thereby optimally adapt the payment methods
to your existing processes. The most central options are described in more detail further below.
By clicking on Install the payment method is activated in your shop. Click Edit in order to modify
the configuration of the payment method.
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5.4 Direct Capturing of Transactions
The option "Capture" allows you to specify if you wish to debit payments directly or if you first
wish to authorise them and then debit the payment at a later point.
Depending on your acquiring contract, a reservation is only guaranteed for a specific period of
time. Should you fail to debit the payment within that period, the authorisation may therefore no
longer be guaranteed. Further information on this process can be found below.

Different settings between Viveum and the module
It may be that settings saved in the payment modules overwrite settings saved in Viveum.

5.5 Uncertain Status
You can specifically label orders for which the money is not guaranteed to be received. This
allows you to manually control the order before shipment.

5.5.1 Setting the order state
For each payment method you may select in which state the order should be set to depending on
the booking state. This is the initial state of the order.

5.6 Optional: Validation
Note: It can be that this option is not visible in your module. In this case just ignore this section.
With the option 'Validation' you can define the moment when the payment method should be
made visible to the customer during the checkout process. This setting is relevant for modules
where the usage depends on the customer's compliance with specific preconditions. For
example, if a solvency check has to be carried out or if the payment method is only available in
certain countries. In order for the credit check or address validation to also work with European
characters, the charset of the "Blowfish mode" must be set to "UTF-8" for certain PSP settings.
You have the choice between these options:
Validation before the selection of the payment method: A validation verification is carried
out before the customer selects the payment method. If the customer does not fulfill the
requirements, the payment method is not displayed
Validation after selection of the payment method: The verification of the compliance
occurs after the selection of the payment method and before the confirmation of the order
During the authorisation: The validation verification is carried out by Viveum during the
authorisation process. The payment method is displayed in any case
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5.6.1 Usage of several independent OpenCart shops
In case you wish to connect several independent shops to one contract with one contract with
Viveum, you require a sellxed payment module for each shop as well as the corresponding multishop module which you will find directly by the payment module.
1. Extract the multi-shop module and open the file "router.php"
2. Enter a shop ID of your choice in the box "Shop ID" within the main configuration of the
module (e.g. shop_a and shop_b)
3. Enter the following line into the corresponding place within the file router.php of the multishop module (for each shop shop_a and shop_b):
$redirect['shop_a'] = 'https://www.your-shop.com/index.php?route=viveumcw/process
/notify';
4. Enter the URL below (instead of the URL mentioned above) under the point "Feedbacks" in
the backend of Viveum: http[s]://yourshop.com/router.php
5. Copy the file router.php into the main directory of your shop
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6 Settings / Configuration of Payment Methods
6.1 General Information About the Payment Methods
The plugin contains the most common payment methods. In case a desired payment method is
not included per default, please contact us directly.
In order to be able to use a payment method, it must be activated in your account with Viveum as
well as in your shop. Information about the configuration of the payment methods can be found
further above.
Below you can find important information for specific payment methods that deviate from the
standard process.

6.2 Information on Payment Status
For each payment method you can define an initial payment status (status for authorized
payments etc.). You hereby define the payment status for each state depending on the
processing type of the order (captured, authorized, etc.). It's the initial status which the order
assumes. Depending on the mutation carried out by you, the status can change.

Important info regarding Order Status
Never set the status to Pending Viveum or any similar pending status which is
implemented by the module.

6.2.1 Order status "pending" / imminent payment (or similar)
Orders with the status 'pending Viveum' are pending orders. Orders are set to that status if a
customer is redirected in order to pay but hasn't returned successfully or the feedback hasn't
reached your shop yet (Customer closed window on the payment page and didn't complete
payment). Depending on the payment method these orders will automatically be transformed
into cancelled orders and the inventory will be cleared (so long as the Cronjob is activated). How
long this takes depends on the characteristics of the payment method and cannot be configured.
If you have a lot of pending orders it usually means that the notifications from your webserver to
Viveum are being blocked. In this case check the settings of your firewall and ask the Hoster to
activate the IPs and User Agents of Viveum.

6.2.2 Order status "cancelled"
Orders with the status "cancelled" have either been set to that status automatically due to a
timeout, as described above, or have been cancelled directly by the customer.
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6.3 Usage Hidden Authorisation / Alias Gateway
You have the possibility of processing credit cards without redirection to the payment page of
Viveum.
In order to be able to use this feature, you must first carry out the steps listed under Hidden
Authorisation / Alias Gateway and create an API-User.
You can then activate the authorisation method 'Hidden Authorisation' for the payment methods
of your choice. This procedure requires you as a merchant to fulfill the PCI-SAQ-A-EP. At no time is
any credit card data saved on your server. Contact your Acquirer for more information about the
SAQ and the requirements.

6.4 Credit Card
For the integration you have the choice between the pre-selection in the shop; i.e. the customer
chooses the card type already in the shop; or a generic integration in which case the customer
only sees the option 'credit card' as a payment method and then chooses the card type on the
payment page Viveum.
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Figure 6.1: No pre-selection of the card type - the type will then be chosen on the payment page.

Pre-Selection of the Payment Method
We recommend choosing the option pre-selection. This allows you to configure individual
settings for each payment method and add payment fees to the various methods.

6.5 PayPal
You can process PayPal directly via Viveum. In order to do so, however, some adjustments to your
PayPal account are required. Please carry out the following steps:
1. Activate the payment module in your shop
2. Make sure that the payment method is activated in your Viveum account
3. The API adjustments must be carried out in your PayPal account. The various steps are
explained in the "PayPal Express Checkout Integration Guide". This document can be found
in your PSP account under: Support > Integration and User Guides > Technical Guides >
Viveum PayPal Express Checkout Integration Guide .

6.6 Usage of the Ajax Authorization (FlexCheckout)
You have the possibility of processing credit cards without redirection to the payment page of
Viveum.
In order to be able to use this feature, you must first carry out the steps listed under Hidden
Authorisation, FlexCheckout (Hosted Tokenization Page), External Checkout und Alias Manager
and create an API-User.
You can then activate the authorisation method 'Ajax Authorization (FlexCheckout)' for the
payment methods of your choice. At no time is any credit card data saved on your server.
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7 The Module in Action
Below you will find an overview of the most important features in the daily usage of the Viveum
module.

7.1 Useful Transaction Information on the Order
You can find an overview of the transaction information in within the order detail view. Among
others, this information allows for the definite attribution of the orders to their corresponding
transaction, seen in the backend of Viveum.

Figure 7.1: Transaction Information in OpenCart.

7.2 Usage of the Alias Managers / Token Solution
With the Alias Manager, your customers can securely save their credit cards with Viveum for later
purchases. You can enable this by activating the option "Alias Manager" in the configuration of
the Payment Method. The customer can then choose from his or her saved credit cards without
having to re-enter all the details.
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Figure 7.1: Alias Manager

Alias Manager Options
The usage of the Alias Managers requires the activation of the correct option with
Viveum. To do so, please contact the support directly.

7.3 Dynamic Template
We provide a standard skin for the usage of the dynamic template for all sellxed modules. You
can activate the option by setting the option "Dynamic Template" to "Use Shop Template" in the
main module. Please make sure that all settings specified under Template have been carried out
in the backend of Viveum.
The Dynamic Template allows you to load the Payment Page of Viveum in the layout of your shop.
The customer, therefore, does not notice that the customer has been forwarded to the website of
Viveum. The template dynamically adjusts to your shop template. This, furthermore, allows you
to easily integrate Mobile Skins (cf. Screenshots).

The Dynamic Template requires an SSL Certificate
In order for the Dynamic Template to work correctly with all browsers, you require an SSL
certificate in your shop.
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Figure 7.1: Example: The skin adapts to the layout of your shop.

Figure 7.1: Example: Dynamic Template with mobile skin

7.4 Capturing / Cancelling of Orders
7.4.1 Capturing Orders
In order to capture orders, open the transaction manager under Sales > Viveum Transactions.
Here you will find an overview of all transactions. Search for the order in the field with the order
numbers. By clicking "view" you will open the transaction of the order.
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7.4.1.1 Capturing Complete Orders or Partial Capturing
By clicking the button "Capture Transaction" a new window opens up. You can now capture every
item individually in case you do not wish to send all items at once. The amount of possible partial
captures depends on your contract. Please contact Viveum directly in order to clarify questions.

Capturing of Orders in the backend of Viveum
The transaction management between your shop and Viveum is not synchronised. If you
capture payments with Viveum, the status in the shop will not be updated and a second
capturing in the shop is not possible.

In case you do not wish to capture all items of an order, you can close the transaction by clicking
the box.

Figure 7.1: Capturing of Orders

Partial Capturing
Please find out if the capturing of partial amounts is supported by your Viveum contract.
If this is not the case, it might happen that the transaction is closed for further
transactions after a partial capture.

7.4.2 Cancel Orders
By clicking "Cancel Transaction", the transaction is cancelled and the reserved amount on your
customer's card is released automatically.
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Figure 7.1: Capture or Cancel in OpenCart.

7.5 Refunding Orders
In order to refund orders, open the transaction information (cf. above).
You can refund individual items or any amount of your choice by modifying the total amount or
the item quantity.

Figure 7.1: Refunds in OpenCart for Viveum.

Maximal Refund
With our module it is not possible to refund more than 100% of the originally authorised
amount.

Executing a refund will not change the status of the order.
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7.6 Setup a Cron Job to Activate the Timed Operations
To activate the timed operations of the plugin (e.g. update service, deleting pending orders, etc.)
make sure that you set up the OpenCart Cron engine. Especially the update function allows you to
automatically retrive additional information or changes of your order directly via the API of
Viveum. Please note it could be that in order to use the update feature it may be necessary that
Viveum activates additional options in your account.
In order to use the timed operations, please schedule a cron job in your server to the following
controller:
https://www.your-shop.com/index.php?route=viveumcw/cron/cron
Here we suggest you use a Cron Engine like for example EasyCron. That way you can This allows
you to open the file ( URL ) with an external service.
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8 Testing
Before switching from test to live mode it is important that you test the module extensively.

Testing
Do not forget to switch the operating mode from test to live after having successfully
tested the module.

8.1 Test Data
In the following section you can find the test data for the various payment methods:
Credit / Debit Card
Card number
Expiry Date
CVC

3750 0000 000 0007
12/2020
1234

American Express

Card number
Expiry Date
CVC

5399 9999 9999 9999
12/2020
123

Mastercard

Card number
Expiry Date
CVC

4111 1111 1111 1111
12/2020
123

VISA (Without 3-D Secure Check)

Card number
Expiry Date
CVC

4000 0000 0000 0002
12/2020
123

VISA (With 3-D Secure Check)

3750 0000 000 0007
12/2020
1234

American Express

5399 9999 9999 9999
12/2020
123

Mastercard

Card number
Expiry Date
CVC

4000 0000 0000 0002
12/2020
123

VISA (With 3-D Secure Check)

Card number
Expiry Date
CVC

4111 1111 1111 1111
12/2020
123

VISA (Without 3-D Secure Check)

American Express
Card number
Expiry Date
CVC
MasterCard
Card number
Expiry Date
CVC
Visa
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9 Errors and their Solutions
You can find detailed information under http://www.sellxed.com/en/faq. Should you not be able
to solve your problem with the provided information, please contact us directly under:
http://www.sellxed.com/en/support

9.1 The Referrer URL appears in my Analytics Tool
When a customer and the notification are redirected via Header Redirection, the Viveum
Referrer URL might appear in your Analytics Tool thus hiding the original traffic source. However,
most Analytic Tools are able to minimize this problem.
In case you are using Google Analytics as reporting tool, this step by step guide may help you to
exclude the URLs: under bullet point 4.
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10 Compatibility with Third-Party Plugins
The plugins listed below are compatible with our payment modules and allow you to handle
certain tasks in an easier way.

10.1 Birthday and gender in OpenCart
For certain payment service providers it is necessary to check the birthday and the gender of a
customer. OpenCart does not check this by default.

How to enable gender and birthday checks in your shops checkout
1. Add two new custom fields to your checkout via your shops backend under
"Customers > Custom Fields"
2. Modify the order context getters to return the value of your custom checkout field
from the order / session (or wherever the previous step saves the data).
Order Context Getters
AbstractOrderContext
getBillingDateOfBirth()
getBillingGender()
These functions can be found in "system/library/cw/Viveum/AbstractOrderContext.
php".
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11 Error Logging
The module will log different unexpected errors or information depending on the configured
level. If there is any issue with the module, this log can help identify the cause.

11.1 Log Levels
You can configure the log level in the Viveum settings.
Error: Logs unexpected errors only. (Default)
Info: Logs extended information.
Debug: Logs information helpful for debugging.

11.2 Log Location
The log file is stored in the default log folder of OpenCart. The path is configured in the config.php
of your shop system. (Default Path: {shopRootDirectory}/system/logs or {shopRootDirectory}
/system/storage/logs)
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12 Advanced Information
This section of the manual is for advanced usage of the module. The content is for advanced
users with special requirements. Everything in this section is optional and not required for the
daily usage of the module.

12.1 Transaction Object
This section describes how to extract information from a transaction, if you need it for further
processing. E.g. you require more information of the transaction for further processing an order
in your ERP system.
The code snippets in this section assume your script resides in the root folder of the shop with
the default shop folder structure.
In your script initialize the base of OpenCart.
Opencart 3.x
require_once('config.php');
require_once(DIR_SYSTEM . 'startup.php');
// Registry
$registry = new Registry();
// Config
$config = new Config();
$config->load('default');
$config->load('catalog');
$registry->set('config', $config);
$loader = new Loader($registry);
$registry->set('load', $loader);
$registry->set('db', new DB($config->get('db_type'), $config->get
('db_hostname'), $config->get('db_username'), $config->get
('db_password'), $config->get('db_database'), $config->get('db_port')));
Include the module specific files and set registry.
require_once DIR_SYSTEM.'library/cw/init.php';
require_once DIR_SYSTEM.'library/cw/ViveumCw/Util.php';
require_once DIR_SYSTEM.'library/cw/ViveumCw/Entity/Transaction.php';
ViveumCw_Util::setRegistry($registry);
Now you can load the transaction and then extract the transactionObject.
Load the transaction by Id:
$transactionById = ViveumCw_Entity_Transaction::loadById($transactionId);
$transactionObject = $transactionById->getTransactionObject();
Load transactions by Order ID:
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$transactionsByOrderId = ViveumCw_Entity_Transaction::
getTransactionsByOrderId($orderId);
foreach($transactionsByOrderId as $transaction){
$transactionObject = $transaction->getTransactionObject();
//Do something with each object
}
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