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1 Introduction

This manual describes the installation, the configuration and the usage of the payment module
for OXID and DocData.

Before you can start with the installation please make sure that you hold all the necessary data.
You need:

® DocData Merchant Name

® DocData Merchant Password

® OXID Payment module from sellxed.com/shop
® |ogin datatoyour server and shop

Note that you must use at least PHP version 5.6 for our plugins. PHP 8 or higher is currently not
supported.

1.1 Procedure of the installation

with this document you'll get all the information you need for the installation of the module. For
the implementation of the module you should follow the checklist strickly. Only like that you can
ensure a safe usage in accordance to all security regulations.

5/26



sellxed

1. Configuration of the DocData Settings

2. Configuration of the main module

3. Configuration of all the accepted Payment method with the authorization methods
included

4. Process a test order

5. Activation of yourDocData account

Installation Service

Our payment plugins should have per default the correct settings for most of our
customers' preferences. That means once you have entered the required credentials in
the plugin configuration to connect your account to your website, the plugin should be
fully operational. Should you be willing to receive detailed information on a setting you
do not know, you may contact our support team who will be able to assist you further.

Our support team is at your disposal during regular business hours at: http://www.
sellxed.com/support. Furthermore, you have the option of ordering our installation
service. We will make sure the plugin is installed correctly in your shop: http://www.
sellxed.com/shop/de/integration-und-installation.htmi

.htaccess Directory Protection

In order to test the module, any kind of directory protection or IP blocking on your server
must be deactivated. This is crucial as otherwise the payment feedback of DocData might
not get through to the shop.

1.2 System Requirements

In general, the plugin has the same system requirements as 0XID. Below you can find the most
important requirements of the plugin:

® PHP Version: 5.4.x or higher

® OpenSSL: Current version with support for TLS 1.2 or higher.

* fsockopen: The PHP function fsockopen must be enabled. The plugin must be able to
connect to external systems over the Internet.

® PHP Functions: All common PHP functions must be enabled.
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2 Configuration DocData - Backend

You'll find an overview about transactions and settings in the backend from DocData:

® Testenvironment:https://test.docdat apaynents. com ps/comtripl edeal.
paynment servi ce. backof fice. Login

® Live environment: htt ps: //backoffi ce. docdat apaynments. coni ps/ com
tripl edeal . paynment servi ce. backoffice.lLogin

2.1 Configuration of the main module

Fill the merchant name and merchant password in the main configuration of the module You can
there additionally choose a default. The default CSS matches the deposited standard CSS
configuration in DocData. You can overwrite these setiings in theconfiguration of the payment
method.

Choose if you want to process the payments in live or test mode.
2.2 Configuration of the payment methods
You can undertake various adjustments for each payment method.

Please keep in mind that in case you want to use the Payment Method Bank Transfer or Open
Invoice (Klarna and AfterPay) you need to activate the feature extendedStatusRequests at
DocData.

2.21 CSSID

Define for each payment method your CSS ID, which you have already set in the backend of
DocData. You can define the CSS profile under Settings > Edit Look and Feel
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| To create a new css, click here! | New css

1 % Select ces

M resets the avtomatic margin and padding of the browser */f
{ |body, html |
margirn:0;
padding:d;
i
*irealid {
box-shadow: none;
[ |
| |= {

!
M sets the standard font *f

af

outline:none;

colon#83A000;
cursor:pointer;

}
body {

color#333;
[ font:12px/18px arial, helvetica, sans-serif;
| background:url(“img/bg_repeater_header.png”) top center repeat-x;

i
| mainLayout{
background:url“ima/alcbe.png”) right bottom no-repeat;
¥
| | headerTitle]
font-weight:beld,

paymentChoiceMenuRow{ i

Figure 2.1: Create CSS profiles under settings > Edit Look and Feel.

2.2.2 Payment Profile

Wwith the payment profile you can select a payment method for the payment page. To do so you
need to create a profile for each payment method in the backend of DocData.

Under Edit > Payment method and names you can create profiles and assign to every profile a
payment method. Fill in the name of the profile into the configuration of the payment method.
This results in the pre selected display of this payment method.
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Assign payment methods to a profile

Select profile: | AMEX + |Add & delete profiles

Available payment methods

AFTERPAY _OPEN INVOICE Selected
BANK_TRANSFER AMEX

EBANKING Add >

ELV

IDEAL

MAESTRO

MASTERCARD

MISTERCASH

PAYPAL EXPRESS CHECKOUT
SEPA DIRECT DEBIT

<« Remove

VISA
First
Up
Diovern
Last
Store changes

Figure 2.1: Creation of payment profiles to select the payment method under Edit > Payment
method and names.

You'll find more information to the configuration of the payment methods and the significance of
the particular settingshere.

2.3 Activation of the Cron Jobs

Since the DocData doesn't send notification answers it can happen that the customer closes the
window before finishing the transaction. In this case we recommend to install Cron Jobs in your
shop. Further information you'll find in the chapterCron Job

2.4 Testing and Activation of the Module

After the activation and configuration of the payment methods, test your module with the test
datayou find in the manual. If the tests were successful, switch to Live in your main module.
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3 Module Installation and Update in the OXID
Shop

3.1 Installation

At this time you should already be in possession of the module. Should this not be the case, you
can download the necessary files in your customer account in the sellxed shop (Menu "My
Downloads Downloads"). In order to install the module in your shop, please carry out the
following steps:

1. Download the plugin. The download can be found in your sellxed.com account under "My
Downloads".

2. Unzip the archive you have just downloaded.

3. Inthe unzipped folder navigate to the folder "files"

4. For some shops there are different versions of the plugin provided. If this is the case open
the folder which corresponds to your shop version.

5. Usingyour preferred FTP client upload entire content of this folder into the root directory
of your shop. For some shops there is a specific folder containing the plugins. If that is the
case upload the plugin into this folder. Make sure that the folders aren't replaced but
merely merged.

6. If you haven't yet done so, log back into your shop.

3.2 Updates and Upgrades

You have direct and unlimited access to updates and upgrades during the duration of your
support contract. In order to receive constant information about available updates we ask you to
subscribe to our RSS feed that we publish for your module.

More information regarding the subscription of this RSS feed can be found under: http://www.
sellxed.com/en/updates_upgrades.

We only recommend an update if something doesn't work in your shop, if you want to use new
feature or if there is a necessary security update.

3.2.1 Update Checklist

We ask you to strictly comply with the checklist below when doing an update:
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1. Always do a backup for your database and your files in your shop

2. Use always a test system to test the update process.

3. Wait until all the files are copied to the shop, clear the cache if there is one in your shop
and then visit the configuration page of the main module so that the update process will
be initialized.

Do not do updates directly in the live environment

Please test the update procedure first in your test shop. Our support team is able and
willing to help you if you experience problems with the update process. However, if you
decide to perform the update directly in your live shop there is the possibility of a
downtime of the shop of more than two days depending on the availability of our support
if you do not want to book our complementary support.

Depending on the version it could be that the database has to be migrated. We recommend you
therefore, to perform the updates in times when the shop is not visited too frequently by your
customers.

3.2.2 Update Instructions

Please always read the update instruction. Those instructions can be found in the changelog. If
there are no special remarks, you can proceed by just overwriting the files in your system.
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4 Module Configuration in the OXID Shop

The configuration consists of two steps. The first step is the configuration of the main module
with all the basic settings (cf. Configuration of the Main Module). During the second step you can
then carry out individual configurations for each payment method . This allows for full flexibility
and perfect adaptation to your processes.

Create backups!

Please create a backup of the main directory of your shop. In case of problems you will
then always be able to return your shop to its original state.

We furthermore recommend testing the integration on a test system. Complications may
arise with third party modules installed by you. In case of questions, our support is gladly
at your disposal.

4.1 Configuration of the Main Module

The settings for the main module can be found under Extensions > Module . Install the module by
clicking Activate.

By clicking on the tab Settings you get to the configuration of the main module. Fill in the boxes
by using the data that you have received from DocData and may have already saved in the
backend of DocData. Each option is additionally explained in a short info text in the shop.

4,11 Settings
4.1.1.1 Update interval for payments

Payments may be updated periodically (interval in minutes). To use this feature you have to
setup a cron job.

4.1.1.2 Order Creation

Choose when the order should be created. If set to 'Before Payment', orders are created in any
case. If set to 'After Payment', an order is created only if the payment is successful.
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4.1.1.3 OrderiID

Use this setting to enforce the behaviour of unique order IDs, even if they are not.

Changing Order Creation and Order ID Settings

Changing these settings may cause duplicate transaction ids to be distributed, which will
cause errors during transaction processing. If you wish to change these after
transactions have been created you must backup then empty the module transaction
table in the database.

4.1.1.4 Delete Orders on Failure

Set to yes to delete the order when the authorization fails. Otherwise the internal order status is
set to 'PAYMENT_FAILED".

4.1.1.5 Logging Level

Messages of this or a higher level will be logged.

41.2 OXID 6 Installation

After uploading the plugin via S/FTP, log into your server via SSH and navigate to the root folder of
OXID. In this directory, run the following commands so the plugin is available in the backend:

command vendor/console/bin oe:module:install-configuration source/modules/customweb
/docdatacw/

php vendor/bin/oe-console oe:module:activate docdatacw

php vendor/bin/oe-console oe:module:apply-configuration
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4.2 Configuration of the Payment Module

After having successfully configured the main module, you can find the settings for the individual

payment methods in your shop under Shop Settings > Payment Methods . Each method is listed
individually.

Install the payment methods you wish to offer your customers. Open the payment method and
tick the box next to Active.

By clicking on DocData Configuration, you can save different settings for each payment method
and thereby optimally adapt the payment methods to your existing processes

Payment Methods not Displayed in the Checkout

Please check if you have attributed the payment method to the available countries as
well as customer groups in case a should payment method not be visible in the checkout.

4.3 Direct Capturing of Transactions

The option "Capture" allows you to specify if you wish to debit payments directly or if you first
wish to authorise them and then debit the payment at a later point.

Depending on your acquiring contract, a reservation is only guaranteed for a specific period of
time. Should you fail to debit the payment within that period, the authorisation may therefore no
longer be guaranteed. Further information on this process can be found below.

Different settings between DocData and the module

It may be that settings saved in the payment modules overwrite settings saved in
DocData.

4.4 Uncertain Status

You can specifically label orders for which the money is not guaranteed to be received. This
allows you to manually control the order before shipment.

441 Setting the order state

For each payment method you may select in which state the order should be set to depending on
the booking state. This is the initial state of the order.
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4.5 Optional: Validation

Note: It can be that this option is not visible in your module. In this case just ignore this section.

with the option 'Validation' you can define the moment when the payment method should be
made visible to the customer during the checkout process. This setting is relevant for modules
where the usage depends on the customer's compliance with specific preconditions. For
example, if a solvency check has to be carried out or if the payment method is only available in
certain countries. In order for the credit check or address validation to also work with European
characters, the charset of the "Blowfish mode" must be set to "UTF-8" for certain PSP settings.

You have the choice between these options:

* Validation before the selection of the payment method: A validation verification is carried
out before the customer selects the payment method. If the customer does not fulfill the
requirements, the payment method is not displayed

* Validation after selection of the payment method: The verification of the compliance
occurs after the selection of the payment method and before the confirmation of the order

* During the authorisation: The validation verification is carried out by DocData during the
authorisation process. The payment method is displayed in any case
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5 Settings / Configuration of Payment Methods
5.1 General Information About the Payment Methods

The plugin contains the most common payment methods. In case a desired payment method is
not included per default, please contact us directly.

In order to be able to use a payment method, it must be activated in your account with DocData
as well as in your shop. Information about the configuration of the payment methods can be
found further above.

Below you can find important information for specific payment methods that deviate from the
standard process.

5.2 Information on Payment Status

For each payment method you can define an initial payment status (status for authorized
payments etc.). You hereby define the payment status for each state depending on the
processing type of the order (captured, authorized, etc.). It's the initial status which the order
assumes. Depending on the mutation carried out by you, the status can change.

Important info regarding Order Status

Never set the status to Pending DocData or any similar pending status which is
implemented by the module.

5.2.1 Order status "pending" / imminent payment (or similar)

Orders with the status 'pending DocData' are pending orders. Orders are set to that status if a
customer is redirected in order to pay but hasn't returned successfully or the feedback hasn't
reached your shop yet (Customer closed window on the payment page and didn't complete
payment). Depending on the payment method these orders will automatically be transformed
into cancelled orders and the inventory will be cleared (so long as the Cronjob is activated). How
long this takes depends on the characteristics of the payment method and cannot be configured.

If you have a lot of pending orders it usually means that the notifications from your webserver to
DocData are being blocked. In this case check the settings of your firewall and ask the Hoster to
activate the IPs and User Agents of DocData.

5.2.2 Order status "cancelled"

Orders with the status "cancelled" have either been set to that status automatically due to a
timeout, as described above, or have been cancelled directly by the customer.

16/26



sellxed

6 The Module in Action

Below you will find an overview of the most important features in the daily usage of the DocData
module.

6.1 Useful Transaction Information on the Order

In the tab DocData Transactions you can find an overview of the transaction information. Among
others, this information allows for the definite attribution of the orders to their corresponding
transaction, seen in the backend of DocData.

Autorisierungsbetrag 947.19
Wahrung EUR
Zahlungsmethode Visa
Zahlungsid 25839786
Verbuchter Betrag 947.19
Transaktion autorisiert Ja
Transaktion ist unsicher Nein
Transaktion verbucht Ja
Transaktion bezahlt Ja
Akzeptanz test123
Kartennummer 20000003
Kartenablaufdatum 12/15
Handler Referenz ox_sel_pf 2

Figure 6.1: Transaction Information in OXID

6.2 Using Invoice Details of a Processor

In the following context you can view or embed the "payment details" of for example an "Open
[nvoice" transaction:

6.2.1 OXID Order Confirmation (E-Mail)

The "payment information" will be visible in the default "order confirmation e-mail" of OXID.

6.2.2 OXID Invoice (PDF)

Due to technical limitations, it is currently not possible to display the "payment information”
here.

6.2.3 0XID-Backend (Transaction details)

You can view the transaction details in OXID under Administer Orders > DocData Transactions.
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HOME SHOP'S START PAGE LOGOUT
MASTER SETTINGS
SHOP SETTINGS TRANSACTION ID ORDER NO.
12 7
11 6
EXTENSIONS 2017-03-07 15:33:56 10 5
2017-03-07 15:30:01 [ 1
ADMINISTER PRODUCTS
ADMINISTER USERS

ADMINISTER ORDERS

Orders

Order Summary

Packing List

CUSTOMER INFO Transaction

STATISTICS Date
Transaction ID 12

SERVICE Order 7| View Order
Authorisation Amount 485.90
Currency EUR
Payment Method Open Invoice
Payment ID 3575603
Test Transaction Yes
Transaction authorised Yes
Transaction uncertain No

Transaction paid

Yes

Payment Information

sellxed

admin

PAYMENT METHOD PAYMENT ID e
Open Invoice 3575603

Open Invoice

MasterCard 3575367

MasterCard 3575361

Transaction Histol

DATE
2017-03-07 18:14:56

Captures

Capturing

Cancellation

Cancel

y

ACTION MESSAGE
authorization The amount of 485.90 is authorized.

Bank: Customweb Test Bank.

Account Holder: Customweb GmbH
IBAN: DE2501200000TEST000000000005
BIC: TESTBICO005.

Reference Number: BP3575603/2749

Figure 6.1: Transaction details within OXID.

6.2.4 OXID Success-Page

oxip eshop -

Kiteboarding ~  Wakeboarding ~

Sie sind hier. / Bastellung al lossan

- EUR -~ Meain Konto - ﬂ

5/

o 2

1. Warenkorblbersicht 2. Adressen wahlen

Vielen Dank

Vielen Dank fur |hre Bestellung im OXID eShop 4.
Ihre Bestellung ist unter der Nummer 7 bei uns registriert
Sie haben bereits eine Bestellbestatigung per E-Mail erhalten.

Sollte etwas nicht lieferbar sein, werden wir Sie sofort informieren.

Ihre Zahlungsinformationen

Bank: Custormweb Test Bank
Kontoinhaber: Customweb GmbH

IBAN: DE2R0O1200000TESTOOO0000000005
BIC: TESTEIC0005

Referenznummer: BP3575603/2749

Sie kénnen nun weiter zur Startseite cder |hre Bestellhistorie aufrufen.

3 Versand & Zahlungsart

Figure 6.1: Payment information on the OXID "Success-Page".

6.3 Capturing / Cancelling of Orders

Our module allow you to capture payments directly from within Oxid eSales without having to log

into DocData.

4. Uberprifen & absenden

Fertig!
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6.3.1 Capturing Orders

In order to capture orders, open the transaction tab (DocData Transactions). By clicking on the
button Capture a new window will open up in which you can capture transactions.

You can now capture each item individually if you don't want to ship them all at once. The

amount of possible partial captures depends on your contract. For more information on this,
please contact DocData directly.

Capturing of Orders in the backend of DocData

The transaction management between your shop and DocData is not synchronised. If you
capture payments with DocData, the status in the shop will not be updated and a second
capturing in the shop is not possible.

| you do not want to capture all items of an orders, click on 'Close transaction for further
captures'.

Teilbuchung
Mit dem folgenden Formular kénnen Sie eine Teilbuchung durchfiihren.

Name: kU Typ Steuersatz

Gesamttotal (exkl. Mwst.) Gesamttotal (inkl. Mwst.)
Trapez ION SOL KITE 2011 1401 product 0%

Menge
2 216.80 216.80
Transportcontainer THE BARREL 3788 product 0% 1 2097 2097
Shipping shipping shipping 0% T 690 690
Gesamtbuchungsbetrag: 244,67 EUR
Transaktion fiir weitere Buchungen schliessen
Buchung

Figure 6.1: Capturing of Orders in OXID eSales.

Partial Capturing

Please find out if the capturing of partial amounts is supported by your DocData contract.
If this is not the case, it might happen that no further captures can be carried out.

6.3.2 Cancelling Orders

By clicking Cancel the transaction is cancelled and the amount reserved on the customer's card
will be released immediately.

6.4 Refunding Orders

In order to refund orders, open the transaction tab (DocData Transactions) and click on Refund. A
new window will open up.

You can refund every item individually or any amount of your choice by modifying the total
amount to pay or the amount of items.
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Teil-Riickvergiitung
Mit dem folgenden Formular kénnen Sie eine Teil-Riickvergiitung durchfiihren.

Name SKU T Steuersatz Menge Gesamttotal (exkl. Mwst.) Gesamttotal (Inkl. Mwst.)

Trapez ION SOL KITE 2011 1401 product 0% 1 I [ e
Shipping shipping shipping 0% 1 [ ]
Gesamtriickverglitungsbetrag: 15,30 EUR
Transaktion fir weitere Riickvergiitungen schliessen
Rilckvergiitung

Figure 6.1: Refunds in OXID eSales for DocData.

Maximal Refund

With our module it is not possible to refund more than 100% of the originally authorised
amount.

Executing a refund will not change the status of the order.

6.5 Setupa CronJob to Activate the Timed Operations

To activate the timed operations of the plugin (e.g. update service, deleting pending orders, etc.)
make sure that you set up the OXID Cron engine. Especially the update function allows you to
automatically retrive additional information or changes of your order directly via the APl of
DocData. Please note it could be that in order to use the update feature it may be necessary that
DocData activates additional options in your account.

In order to use the timed operations, please schedule a cron job in your server to the following
controller:

http://urltoyourstore.com/index.php?cl=docdatacw_cron

Here we suggest you use a Cron Engine like for example EasyCron. That way you can This allows
you to open the file (URL) with an external service.
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Before switching from test to live mode it is important that you test the module extensively.

Testing

Do not forget to switch the operating mode from test to live after having successfully

tested the module.

7.1 Test Data

In the following section you can find the test data for the various payment methods:

Credit / Debit Card
VISA

Card number
Expiry Date

Name

CID

3D-Secure

Mastercard
Card number
Expiry Date
Name

CID
3D-Secure

American Express
Card number
Expiry Date
Name

CID

Maestro
Card number
Expiry Date
Name

CID
3D-Secure

Bancontact Mister Cash

Card number
Expiry Date
Name

CID

MasterCard

41111111 11111111
03/2027

Hans Muster

333

ECI=5

5100 0000 0000 0008
03/2027

Hans Muster

333

EClI=2

341111111111 111
03/2027

Hans Muster

2234

6703 0500 0340 17105
09/2022

Hans Muster

333

ECI=2

6703 0500 0340 53002
09/2022

Hans Muster

333

VISA

Mastercard

American Express

Maestro

Bancontact Mister Cash
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Mastercard
Card number
Expiry Date
Name

CID
3D-Secure

Maestro
Maestro
Card number
Expiry Date
Name

CID
3D-Secure

Visa

VISA

Card number
Expiry Date
Name

CID
3D-Secure

American Express
American Express

Card number
Expiry Date
Name

CID

Bancontact

Bancontact Mister Cash

Card number
Expiry Date
Name

CID

5100 0000 0000 0008
03/2027

Hans Muster

333

EClI=2

6703 0500 0340 17105
09/2022

Hans Muster

333

EClI=2

41111111 11111111
03/2027

Hans Muster

333

ECI=5

34111111 1111111
03/2027

Hans Muster

2234

6703 0500 0340 53002
09/2022

Hans Muster

333

sellxed

Mastercard

Maestro

VISA

American Express

Bancontact Mister Cash
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8 Errors and their Solutions

You can find detailed information under http://www.sellxed.com/en/fag. Should you not be able
to solve your problem with the provided information, please contact us directly under:
http://www.sellxed.com/en/support

8.1 The Referrer URL appears in my Analytics Tool

when a customer and the notification are redirected via Header Redirection, the DocData
Referrer URL might appear in your Analytics Tool thus hiding the original traffic source. However,
most Analytic Tools are able to minimize this problem.

In case you are using Google Analytics as reporting tool, this step by step guide may help you to
exclude the URLs: under bullet point 4.

23/26


http://www.sellxed.com/en/faq
http://www.sellxed.com/en/support
http://www.optimizesmart.com/tracking-true-referrals-in-google-analytics-when-using-paypal-and-other-payment-gateways/

sellxed

9 Compatibility with Third-Party Plugins

The plugins listed below are compatible with our payment modules and allow you to handle
certain tasks in an easier way.

9.1 Birthday and genderin OXID

For certain payment service providers it is necessary to check the birthday and the gender of a
customer. OXID does not check this by default. These checks can be enabled under "Settings >
Other Settings > Mandatory fields in User Registration Form".
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10 Error Logging

The module will log different unexpected errors or information depending on the configured
level. If there is any issue with the module, this l0og can help identify the cause.

10.1 Log Levels
You can configure the log level in the DocData settings.

® Error: Logs unexpected errors only. (Default)
* [nfo: Logs extended information.
® Debug: Logs information helpful for debugging.

10.2 Log Location

The log file is stored in the OXID log directory. Please make sure the folder and it is writable by the
webserver. (Default Path: {shopRootDirectory}/l0gs/)
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11 Advanced Information

This section of the manual is for advanced usage of the module. The content is for advanced
users with special requirements. Everything in this section is optional and not required for the
daily usage of the module.

11.1 Transaction Object

This section describes how to extract information from a transaction, if you need it for further
processing. E.g. you require more information of the transaction for further processing an order
inyour ERP system.

The code snippets in this section assume your script resides in the root folder of the shop with
the default shop folder structure.

Have OXID initialized in your script, this is required for the database connection.
require_once dirnane(__FILE ) . "/bootstrap. php";

Include the module module classes.

requi re_once 'nodul es/ cust omneb/ docdat acw/ cl asses/ DocDat aCwHel per . php'

Now you can load the transaction and then extract the transactionObject.
Load the transaction by Id:

$transacti onByl d = DocDat aCwHel per: : | oadTransaction(transactionld);
$transacti onChj ect = $transacti onByl d->get Transacti onCbj ect () ;
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