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Introduction to the Installation of PostFinance

First of all, thank you very much for your purchase of the PostFinance module and for having confidence in us.
Before beginning with the installation, you need the login details for the administration user interface of
PostFinance. For this you require a contract with PostFinance which can be ordered under PostFinance contract or

directly by contacting us per telephone.

Once you have the account details, you can log into the back-end under http://e-payment.postfinance.ch.
Procedure

The usual procedure includes your receiving of the test-login details (recognisable due to the PSPID ending in TEST).
The module should be tested extensively within this trial phase. If the tests were successful, you can contact

PostFinance directly under merchanthelp [at] postfinance.ch and request the switch of your PSPID to going live.
PostFinance will then gladly take care of the rest for you. You will merely have to set your module to live processing.

ConfiguratiomBack-#me-(Restrinance

As mentioned before, you must use your account details, which you have received from PostFinance in order to log
into _http://e-payment.postfinance.ch.

In order to be able to work with the module you have to change some settings in the administrator user interface

under "Technical Information”. In the following we will only mention those settings which are relevant for the
interaction between the PostFinance gateway and the module.

Global transaction parameter

For this paragraph you should read the comments for the respective options and fill it in according to your needs.
These options have an influence on the handling of payments. They are relevant for the process of how to handle
payments but not for the actual interaction between the shop and the PostFinance API.

Before beginning with the configuration you must set a SHA-1-IN pass phrase. Please go to the section Data and
origin verification further below and then return to Global transaction parameters and continue with the point
Default operation code.

Default operation code

We recommend the option “sale", in that case all incoming payments will be processed and billed directly.
Payment retry

We recommend setting the counter to "10".

Processing for individual transactions

We recommend the option "Online but switch to offline when the online acquiring system is unavailable.”

Default ECI value

We recommend choosing the value "7 - eCommerce with SSL-encryption".
Global security parameters

Here you can set the security parameters for the interaction between the shop and the gateway of PostFinance. It is
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important that you set the same configurations as in your shop module. You should set the sign encodings to
UTF-8. You can not change this in the module. Furthermore, please pay attention towards the fact that SHA-256 or
SHA-512 Hash-methods require at least PHP 5.1.2.

Hashing methods

We recommend choosing SHA-512 and UTF-8 encoding. Please pay attention to the fact that SHA-256 or SHA-512
Hash-methods require at least PHP 5.1.2.

Template

Tick "No" for the enabling of JavaScript.
The static template is not supported by our module. You must therefore tick "no" for the usage of static template.

Enter the host-name into the lower box, e.g. http://yourshop.com. The upper box should remain empty.
Data and origin verification

In this paragraph the data required for the verification of the origin of payments is determined. Only the field
"Verifications for e-Commerce" is relevant. Do not enter anything under URL of the merchant page.

"SHA-1-IN pass phrase" is a security component of the payment which verifies its genuineness. It is, therefore,
important that you use the same pass phrase in the back-end as in the shop. In order to generate an easy pass
phrase we recommend you to use the Ogone SHA-1 pass phrase generator of customweb Ltd.

If the Direct Link option is activated for your account, you will have to enter the SHA-IN pass phrase for Direct Link.
This pass phrase must be identical to the SHA-IN pass phrase for e-commerce!

Transaction feedback
The parameter of the transaction feedback defines the processing in the shop after the payment has been effected.

¢ Nothing has to be entered in the four boxes under "http-redirection in the browser as this is carried out by
our module.

o Leave the box "l would like to receive transaction feedback parameters..."

e Check the box "I would like the PSP to display..."

Direct HTTP-server-to-server request

Under "Direct HTTP-server-to-server request” we advise you to chose the settings listed below. Furthermore, you
must enter the listed URL of the merchant page in both of the fields.

¢ The request type must be set to "always online (directly after the payment...)"
e The URL of the merchant site to which the transaction feedback should be sent must be defined in both
boxes. Please use the following URL:

http://www.shop-
url.com/index.php?option=com_jshopping&controller=checkout&task=step7&act=notify&no_lang=1

Please make sure that you are using the correct protocol (https:// or http://)

¢ As request method you should use "POST"
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Dynamic e-Commerce parameters

No changes have to be made

General

Tick both boxes

Security for request parameters

The box "SHA-1-0OUT pass phrase" is a further security mechanism of the payment. Here too, the chosen signature
must be identical to the one in the shop. Please make sure, however, that the SHA-1 OUT pass phrase is different
from the SHA-1IN. For this you may use our pass phrase generator

HTTP request for status changes

Chose the option "no request" and leave the box empty

Transactions e-mails

Here you can configure your e-mail settings. In general no configuration is needed for the standard usage. If you
nevertheless want to change the configuration, we recommend the following settings:

e Yes for all transaction submission modes

Modutetnstaliationdn the Shop (Joomla!
Joomshopping)

1. Extract the ZIP file sent to you by us (e.g. with WinRAR; http://www.winrar.de/)

2. Log into the back-end of your shop

3. Go to "Extensions->Install/Uninstall”

4. Enter the ZIP Archive, which you will find in the extracted archive, into ,,Upload package data“
5. Click "Upload data & install”

Configuration of the Module in the Shop

Configuration of the Main Module

In order to configure the main module you must go to Components > PSP (e.g. PostFinance, Viveum, etc) and click
on 'Options'. Now configure it according to the back-end of the PSP. It is absolutely crucial that the settings in your
shop system are identical to those of your PSP!

In case you can not configure the module in the shop the shop system has probably blocked the upload of the

module, i.e. not all files were installed. You must, therefore, change the File-Permission and upload/install the ZIP
archive anew.

Configuration of the Payment Methods
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Under Components > Joomshopping > Options > Payment you will find a list of payment methods. Activate the
payment methods supported by your contract package with your PSP.

Important: For Joomla! Joomshopping you must save the payment methods a second time right in the end.

egtimerhedntegration

Generally, you will first receive a test account (PSPID ends with "TEST"). With this test account you can try out the
functionalities of the module. A test order is usually required before the account goes live.

Activate Live Mode

In the module-configuration you can switch from "live" to "test". Through this, the correct configuration for the test
will automatically be used. You will find the test details in the back-end under technical information » Test-Info orin
this document further below.

Please contact you Payment Service Provider. . It is important that you carry out this switch. Executed orders will
fiege Eredit-tcard Data
In order to test the module, Iease. go to htti://vvvvvv.selIxed.com/en/testing. All relevant test card data is listed

trrors and Their Solutions

In the following passage you will find the various known problems and the solutions to them. In case you have a
problem it is best to thoroughly read through the following chapters. If this does not help you, contact us and we
will surely find a solution.

Error code

Error description

Solutions

unknown order/1/r

unknown order/0/s/

unknown order/0/x///FIN

unknown order/1/s/

unknown order/0/r/
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The registered referrer in the
Payment Service Provider's (PSP)
back-end does not coincide with the

referrer transmitted by the browser.

No SHA signature is transmitted.

An error has occurred in connection
with XML requests.

The calculated hash values and the
transmitted hash values do not
coincide.

The browser does not acknowledge
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Either you don't enter anything
under'Referrer', thennoverification
will occur, oryou control the referrer
again and pay attention to the
protocol.

You must define the signatures in
the module and in the Payment
Service Provider's back-end.

If you have this problem please
contact us.

Either something has been
incorrectly set up for the calculation
method (global security parameter;
not the same settings in the shop
back-end as inthe PSP's back-end);
the signaturesinthe shop back-end
do not coincide with those of the
Payment Service Provider's back-
end; or the PSP ID has not been
entered identically as shown in the
one of the PSP. The PSP ID is case
sensitive.

The problem lies within your
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your confirmation. browser.

unknown order/1/x/ A configuration in the Payment In this case please contact the
Service Provider's back-end is not  merchant help of Payment Service
allowed. Provider's.

Orders aren't registered

The problem arises with certain server configurations that the order isn't correctly processed after the payment
process. This becomes evident especially in cases where, e.g. the shopping cart is not emptied after the order has
been affected or no e-mail confirmation is sent out.

[ | ]

BastEinance:jopomiatloomshopping:

ro rverimoti i avpi i g =1 timfa hat dPels he
Payment Service Provider server is being blocked. Furthermore, it is possible that the User Agent of the Payment
trstaltatrotr-Manual
In order to solve this problem you must make sure that your host configures the Firewall in such a manner that
correspondingly and that it doesn't block the IP addresses of the Payment Service Provider's server. You will find the
futar eustermveh.GrmbHend of your PSP under Support » FAQ » Integration. In order to avoid the blocking of the

EJ-SQFWQ@MZ%& must see with your host if any modules are installed which may block the User Agent. These must
then be deactivated.

Display Dynamic Template
Bxtassiyaabaletieobirtes with the:displayof the dynamigtemplatel this can have several causes.

Error description Solutions

Template file isn't being loaded. The payment maskis  This can have several reasons:
displayed in the design of the PSP.
e Please make sure that the settings under
'Template' (cf. above, especially the protocol of
the host-name) have been correctly configured.
e The server of the Payment Service Provider is
being blocked (cf. preceeding section).

CSS file isn't being loading. Certain browsers prohibit the loading of CSS files from
"untrusted" resources. A smooth usage of the dynamic
template requires a SSL-certificate.

Missing Base-tag If you are using the template function, it is possible
that the CSS files and the pictures aren't loaded in the
PSP's interface. The solution is to insert the base-tag
at the beginning of the "<head>" tags in the template:
<base href="http(s)://www.your-store.com/your-dir/"
/>
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Introduction to the Installation of PostFinance

First of all, thank you very much for your purchase of the PostFinance module and for having confidence in us.
Before beginning with the installation, you need the login details for the administration user interface of
PostFinance. For this you require a contract with PostFinance which can be ordered under PostFinance contract or

directly by contacting us per telephone.

Once you have the account details, you can log into the back-end under http://e-payment.postfinance.ch.
Procedure

The usual procedure includes your receiving of the test-login details (recognisable due to the PSPID ending in TEST).
The module should be tested extensively within this trial phase. If the tests were successful, you can contact

PostFinance directly under merchanthelp [at] postfinance.ch and request the switch of your PSPID to going live.
PostFinance will then gladly take care of the rest for you. You will merely have to set your module to live processing.

ConfiguratiomBack-#me-(Restrinance

As mentioned before, you must use your account details, which you have received from PostFinance in order to log
into _http://e-payment.postfinance.ch.

In order to be able to work with the module you have to change some settings in the administrator user interface

under "Technical Information”. In the following we will only mention those settings which are relevant for the
interaction between the PostFinance gateway and the module.

Global transaction parameter

For this paragraph you should read the comments for the respective options and fill it in according to your needs.
These options have an influence on the handling of payments. They are relevant for the process of how to handle
payments but not for the actual interaction between the shop and the PostFinance API.

Before beginning with the configuration you must set a SHA-1-IN pass phrase. Please go to the section Data and
origin verification further below and then return to Global transaction parameters and continue with the point
Default operation code.

Default operation code

We recommend the option "sale", in that case all incoming payments will be processed and billed directly.
Payment retry

We recommend setting the counter to "10".

Processing for individual transactions

We recommend the option "Online but switch to offline when the online acquiring system is unavailable.”

Default ECI value

We recommend choosing the value "7 - eCommerce with SSL-encryption".

Global security parameters
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Here you can set the security parameters for the interaction between the shop and the gateway of PostFinance. It is
important that you set the same configurations as in your shop module. You should set the sign encodings to
UTF-8. You can not change this in the module. Furthermore, please pay attention towards the fact that SHA-256 or
SHA-512 Hash-methods require at least PHP 5.1.2.

Hashing methods

We recommend choosing SHA-512 and UTF-8 encoding. Please pay attention to the fact that SHA-256 or SHA-512
Hash-methods require at least PHP 5.1.2.

Template

Tick "No" for the enabling of JavaScript.
The static template is not supported by our module. You must therefore tick "no" for the usage of static template.

Enter the host-name into the lower box, e.g. http://yourshop.com. The upper box should remain empty.

Data and origin verification

In this paragraph the data required for the verification of the origin of payments is determined. Only the field
"Verifications for e-Commerce" is relevant. Do not enter anything under URL of the merchant page.

"SHA-1-IN pass phrase" is a security component of the payment which verifies its genuineness. It is, therefore,
important that you use the same pass phrase in the back-end as in the shop. In order to generate an easy pass
phrase we recommend you to use the Ogone SHA-1 pass phrase generator of customweb Ltd.

If the Direct Link option is activated for your account, you will have to enter the SHA-IN pass phrase for Direct Link.
This pass phrase must be identical to the SHA-IN pass phrase for e-commerce!

Transaction feedback
The parameter of the transaction feedback defines the processing in the shop after the payment has been effected.

¢ Nothing has to be entered in the four boxes under "http-redirection in the browser as this is carried out by
our module.

e Leave the box "l would like to receive transaction feedback parameters..."

e Check the box "l would like the PSP to display..."

Direct HTTP-server-to-server request

Under "Direct HTTP-server-to-server request" we advise you to chose the settings listed below. Furthermore, you
must enter the listed URL of the merchant page in both of the fields.

[ ]

e The request type must be set to "always online (directly after the payment...)"

e The URL of the merchant site to which the transaction feedback should be sent must be defined in both
boxes. Please use the following URL:

http://www.shop-
url.com/index.php?option=com_jshopping&controller=checkout&task=step7&act=notify&no_lang=1

Please make sure that you are using the correct protocol (https:// or http://)
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¢ As request method you should use "POST"

Dynamic e-Commerce parameters

No changes have to be made

General

Tick both boxes

Security for request parameters

The box "SHA-1-0OUT pass phrase" is a further security mechanism of the payment. Here too, the chosen signature
must be identical to the one in the shop. Please make sure, however, that the SHA-1 OUT pass phrase is different
from the SHA-1IN. For this you may use our pass phrase generator

HTTP request for status changes

Chose the option "no request" and leave the box empty

Transactions e-mails

Here you can configure your e-mail settings. In general no configuration is needed for the standard usage. If you
nevertheless want to change the configuration, we recommend the following settings:

¢ Yes for all transaction submission modes

Modiuetnstaliationdn the Shop (Joomla!
Joomshopping)

1. Extract the ZIP file sent to you by us (e.g. with WinRAR; http://www.winrar.de/)

2. Log into the back-end of your shop

3. Go to "Extensions->Install/Uninstall”

4. Enter the ZIP Archive, which you will find in the extracted archive, into ,,Upload package data“
5. Click "Upload data & install”

Configuration of the Module in the Shop
Configuration of the Main Module

In order to configure the main module you must go to Components > PSP (e.g. PostFinance, Viveum, etc) and click
on 'Options'. Now configure it according to the back-end of the PSP. It is absolutely crucial that the settings in your
shop system are identical to those of your PSP!

In case you can not configure the module in the shop the shop system has probably blocked the upload of the
module, i.e. not all files were installed. You must, therefore, change the File-Permission and upload/install the ZIP
archive anew.
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Configuration of the Payment Methods

Under Components > Joomshopping > Options > Payment you will find a list of payment methods. Activate the
payment methods supported by your contract package with your PSP.

q_pt)rtant For Joomla! Joomshopping you must save the payment methods a second time right in the end.

egtimgrrhedntegration

Generally, you will first receive a test account (PSPID ends with "TEST"). With this test account you can try out the
functionalities of the module. A test order is usually required before the account goes live.

Activate Live Mode

In the module-configuration you can switch from "live" to "test". Through this, the correct configuration for the test
will automatically be used. You will find the test details in the back-end under technical information » Test-Info or in
this document further below.

Please contact you Payment Service Provider. . It is important that you carry out this switch. Executed orders will
fiege Eregit-tbard Data

In order to test the module, Flease go to htti /Jwww.sellxed.com/en/testing. All relevant test card data is listed
t=rrors and Their Solutions

In the following passage you will find the various known problems and the solutions to them. In case you have a
problem it is best to thoroughly read through the following chapters. If this does not help you, contact us and we
will surely find a solution.

Error code

Error description

Solutions

unknown order/1/r

unknown order/0/s/

unknown order/0/x///FIN

unknown order/1/s/
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The registered referrer in the
Payment Service Provider's (PSP)
back-end does not coincide with the

referrer transmitted by the browser.

No SHA signature is transmitted.

An error has occurred in connection
with XML requests.

The calculated hash values and the
transmitted hash values do not
coincide.
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Either you don't enter anything
under'Referrer', then noverification
will occur, oryou control the referrer
again and pay attention to the
protocol.

You must define the signatures in
the module and in the Payment
Service Provider's back-end.

If you have this problem please
contact us.

Either something has been
incorrectly set up for the calculation
method (global security parameter;
not the same settings in the shop
back-end as inthe PSP's back-end);
the signaturesin the shop back-end
do not coincide with those of the
Payment Service Provider's back-
end; or the PSP ID has not been
entered identically as shown in the
one of the PSP. The PSP ID is case
sensitive.
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Introduction to the Installation of PostFinance
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your confirmation.
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PostFinance. For this you require a contégﬁl\é\gt 9?&5@395&3\@@ gaHotEe OrH'FJF&EH{jﬂeIp of Payment Service or

directly by contacting us per telephone. allowed. Provider's.

8 de you have,the account aetails, you can log into the back-end under
ers aren't registere

Proce
The pro %Ham arises with certain server configurations that the order isn't correctly processed after the payment
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Chnt mﬁéﬁwﬁ b
@ i\/ Plé t&hl’ﬁ rAgent of the Payment
ﬁg%%ﬂ%’éﬁeﬁéfﬁ?é‘,’%ﬁ H’ﬁﬁggl?_l.%c\ft?ﬁlr account details, which you have received from PostFinance in order to log

into
In order to solve this problem you must make sure that your host configures the Firewall in such a manner that
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then be deactivated.

Global transactjon arameter
Display Dynamic Template

For this paragraph you should read the comments for the respective options and fill it in according to your needs.
hERRCoORRVA R i MR ANsdinRl RuRfiRE AYRAIndRIEPRIE, O GRT03ME FEVEFR PRUSESs of how to handle

payments but not for the actual interaction between the shop and the PostFinance API.
Error descnptmn Solutlons

°?|§mpmﬁdﬂtiﬁhtfhethgﬂwéﬂl Ihe paummmsdx GIobaThriﬁiﬁdnime pevambmsmsd continue Wlth the p0|nt
Deiznlryegdrtimdesien of the PSP.

o Please make sure that the settings under
Default operation code 'Template' (cf. above, especially the protocol of
the host-name) have been correctly configured.

We recommend the option "sale", in that case all incoming paymenidiaHebeep aicese &taume oileervicedtrgvider is
being blocked (cf. preceeding section).
ment retry
¥S fileisn't bemg loading. Certain browsers prohibit the loading of CSS files from
"untrusted" resources. A smooth usage of the dynamic

We recommend setting the counter to "10".
template requires a SSL-certificate.

Pmcessmg afor_%ndlwdual transactions

ssing If you are using the template function, it is possible

We recommend the option "Online but switch to offline wh%%E}]Ster:ﬁ?ifséE\!:e@sq.'.ﬁrﬁquégyets%éﬁi{egrl?églegrlt af Fedzgslg 122
at the beginning of the "<head>" tags in the template:

Default ECI value <base href="http(s):// B

We recommend choosing the value "7 - eCommerce with SS{_?encryption".
Global security parameters

Here you can set the security parameters for the interaction between the shop and the gateway of PostFinance. It is
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important that you set the same configurations as in your shop module. You should set the sign encodings to
UTF-8. You can not change this in the module. Furthermore, please pay attention towards the fact that SHA-256 or
SHA-512 Hash-methods require at least PHP 5.1.2.

Hashing methods

We recommend choosing SHA-512 and UTF-8 encoding. Please pay attention to the fact that SHA-256 or SHA-512
Hash-methods require at least PHP 5.1.2.

Template

Tick "No" for the enabling of JavaScript.
The static template is not supported by our module. You must therefore tick "no" for the usage of static template.

Enter the host-name into the lower box, e.g. http://yourshop.com. The upper box should remain empty.
Data and origin verification

In this paragraph the data required for the verification of the origin of payments is determined. Only the field
"Verifications for e-Commerce" is relevant. Do not enter anything under URL of the merchant page.

"SHA-1-IN pass phrase" is a security component of the payment which verifies its genuineness. It is, therefore,
important that you use the same pass phrase in the back-end as in the shop. In order to generate an easy pass
phrase we recommend you to use the Ogone SHA-1 pass phrase generator of customweb Ltd.

If the Direct Link option is activated for your account, you will have to enter the SHA-IN pass phrase for Direct Link.
This pass phrase must be identical to the SHA-IN pass phrase for e-commerce!

Transaction feedback
The parameter of the transaction feedback defines the processing in the shop after the payment has been effected.

¢ Nothing has to be entered in the four boxes under "http-redirection in the browser as this is carried out by
our module.

o Leave the box "l would like to receive transaction feedback parameters..."

e Check the box "I would like the PSP to display..."

Direct HTTP-server-to-server request

Under "Direct HTTP-server-to-server request” we advise you to chose the settings listed below. Furthermore, you
must enter the listed URL of the merchant page in both of the fields.

¢ The request type must be set to "always online (directly after the payment...)"
e The URL of the merchant site to which the transaction feedback should be sent must be defined in both
boxes. Please use the following URL:

http://www.shop-
url.com/index.php?option=com_jshopping&controller=checkout&task=step7&act=notify&no_lang=1

Please make sure that you are using the correct protocol (https:// or http://)

¢ As request method you should use "POST"
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Dynamic e-Commerce parameters

No changes have to be made

General

Tick both boxes

Security for request parameters

The box "SHA-1-0OUT pass phrase" is a further security mechanism of the payment. Here too, the chosen signature
must be identical to the one in the shop. Please make sure, however, that the SHA-1 OUT pass phrase is different
from the SHA-1IN. For this you may use our pass phrase generator

HTTP request for status changes

Chose the option "no request" and leave the box empty

Transactions e-mails

Here you can configure your e-mail settings. In general no configuration is needed for the standard usage. If you
nevertheless want to change the configuration, we recommend the following settings:

e Yes for all transaction submission modes

Modutetnstaliationdn the Shop (Joomla!
Joomshopping)

1. Extract the ZIP file sent to you by us (e.g. with WinRAR; http://www.winrar.de/)

2. Log into the back-end of your shop

3. Go to "Extensions->Install/Uninstall”

4. Enter the ZIP Archive, which you will find in the extracted archive, into ,,Upload package data“
5. Click "Upload data & install”

Configuration of the Module in the Shop

Configuration of the Main Module

In order to configure the main module you must go to Components > PSP (e.g. PostFinance, Viveum, etc) and click
on 'Options'. Now configure it according to the back-end of the PSP. It is absolutely crucial that the settings in your
shop system are identical to those of your PSP!

In case you can not configure the module in the shop the shop system has probably blocked the upload of the

module, i.e. not all files were installed. You must, therefore, change the File-Permission and upload/install the ZIP
archive anew.

Configuration of the Payment Methods
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Under Components > Joomshopping > Options > Payment you will find a list of payment methods. Activate the
payment methods supported by your contract package with your PSP.

Important: For Joomla! Joomshopping you must save the payment methods a second time right in the end.

egtimerhedntegration

Generally, you will first receive a test account (PSPID ends with "TEST"). With this test account you can try out the
functionalities of the module. A test order is usually required before the account goes live.

Activate Live Mode

In the module-configuration you can switch from "live" to "test". Through this, the correct configuration for the test
will automatically be used. You will find the test details in the back-end under technical information » Test-Info orin
this document further below.

Please contact you Payment Service Provider. . It is important that you carry out this switch. Executed orders will
fiege Eredit-tcard Data
In order to test the module, Iease. go to htti://vvvvvv.selIxed.com/en/testing. All relevant test card data is listed

trrors and Their Solutions

In the following passage you will find the various known problems and the solutions to them. In case you have a
problem it is best to thoroughly read through the following chapters. If this does not help you, contact us and we
will surely find a solution.

Error code

Error description

Solutions

unknown order/1/r

unknown order/0/s/

unknown order/0/x///FIN

unknown order/1/s/

unknown order/0/r/
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The registered referrer in the
Payment Service Provider's (PSP)
back-end does not coincide with the

referrer transmitted by the browser.

No SHA signature is transmitted.

An error has occurred in connection
with XML requests.

The calculated hash values and the
transmitted hash values do not
coincide.

The browser does not acknowledge
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Either you don't enter anything
under'Referrer', thennoverification
will occur, oryou control the referrer
again and pay attention to the
protocol.

You must define the signatures in
the module and in the Payment
Service Provider's back-end.

If you have this problem please
contact us.

Either something has been
incorrectly set up for the calculation
method (global security parameter;
not the same settings in the shop
back-end as inthe PSP's back-end);
the signaturesinthe shop back-end
do not coincide with those of the
Payment Service Provider's back-
end; or the PSP ID has not been
entered identically as shown in the
one of the PSP. The PSP ID is case
sensitive.

The problem lies within your
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your confirmation. browser.

unknown order/1/x/ A configuration in the Payment In this case please contact the
Service Provider's back-end is not  merchant help of Payment Service
allowed. Provider's.

Orders aren't registered

The problem arises with certain server configurations that the order isn't correctly processed after the payment
process. This becomes evident especially in cases where, e.g. the shopping cart is not emptied after the order has
been affected or no e-mail confirmation is sent out.

The reason for this is that the server blocks the appeal of the PSP server. This can be caused by your Firewall or also
through server modules intending to avoid spamming on your website. It may be that the IP address of the
Payment Service Provider server is being blocked. Furthermore, it is possible that the User Agent of the Payment
Service Provider's server is being blocked.

In order to solve this problem you must make sure that your host configures the Firewall in such a manner that
correspondingly and that it doesn't block the IP addresses of the Payment Service Provider's server. You will find the
IP addresses in the back-end of your PSP under Support » FAQ » Integration. In order to avoid the blocking of the

User Agent you must see with your host if any modules are installed which may block the User Agent. These must
then be deactivated.

Display Dynamic Template

In case you have problems with the display of the dynamic template this can have several causes.

Error description Solutions

Template file isn't being loaded. The payment maskis  This can have several reasons:
displayed in the design of the PSP.
e Please make sure that the settings under
'Template' (cf. above, especially the protocol of
the host-name) have been correctly configured.
e The server of the Payment Service Provider is
being blocked (cf. preceeding section).

CSS file isn't being loading. Certain browsers prohibit the loading of CSS files from
"untrusted" resources. A smooth usage of the dynamic
template requires a SSL-certificate.

Missing Base-tag If you are using the template function, it is possible
that the CSS files and the pictures aren't loaded in the
PSP's interface. The solution is to insert the base-tag
at the beginning of the "<head>" tags in the template:
<base href="http(s)://www.your-store.com/your-dir/"
/>
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